Asterisk ha and iax problems with floating ip

Hi there, as title suggests i got an asterisk HA solution with 2 servers drbd and heartbeat, my extensions all use iax protocol which works fine if i connect directly to server 1 ip but fails with the floating ip sip works fine but i just use iax

each of my 2 servers have 2 interfaces one connected to switch the other is between each other for the heartbeat

from what i have read this would be solved if i BIND the virtual ip to my iax but have done that to no avail any other solutions? cheers

solved the issue by adding this routing table

route add -net 192.168.100.0 netmask 255.255.255.0 dev eth1:HA
ip route flush cache

login as: root
[email protected]’s password:

BusyBox v1.16.1 (2015-06-29 18:21:52 CST) built-in shell (ash)
Enter ‘help’ for a list of built-in commands.

cluster> ip route list
default via 192.168.100.1 dev eth1
169.254.0.0/16 dev eth0 proto kernel scope link src 169.254.197.22
169.254.1.0/30 dev eth0 proto kernel scope link src 169.254.1.2
192.168.100.0/24 dev eth1 scope link src 192.168.100.200
192.168.100.0/24 dev eth1 scope link src 192.168.100.202
cluster>

192.168.100.200 is the floating ip and 192.168.100.202 the physical interface

cheers

1 Like

i was thinking on how to direct all traffic to eth1 too. thanks for the gude.