Asterisk FreePBX installed on root server with public IP - phones cannot register


(Martin Ohlenburg Schmidt) #1

Hello everyone and nice that I found this forum, because I’ve been grappling with a problem for some time.

Background

Several locations should be accessible via VoiP by phone. Since we had a previously unused root server up our sleeve,
we decided to install Asterisk 16 on this FreePBX 15. The server is located in a data center and has
via a public fixed IP address.

The installation worked and the dashboard no longer shows any errors after the basic setup has been completed.

Problem

However, no phones can be registered on the server. Regardless of the Sip driver, the clients always return a Timed Out.
This applies to both softphones and hardware.

Since the whole thing now takes days, I hope that someone can give me a tip here, because the server itself seems to be working properly.

Many thanks in advance for any help.

PS: Almost forgotten - an appropriate installation in a local network worked perfectly.


#2

Logs, logs, logs.No logs and everything is a guess.


(Tom Ray) #3

If you are trying to register a device and it returns a 408 Timeout that means the request timed out when trying to register. It didn’t get a reply back from the server.

That means either 1) The system got the request, send back the auth challenge, the other side never got it (NAT issue) and so it times out. 2) The system never got the request.

Because this doesn’t go through any firewalls or have the other side behind a home router/NAT.

Is there an external firewall in front of the PBX at the data center? Is the System Firewall on the PBX active and not setup to allow unknown access?


(Dave Burgess) #4

There are two classes of SIP phones - Local network and remote. You say “No” phones are working, and then you say your internal phones are working fine. Which is it?

If only your external phones are not working, it is almost certainly a routing/firewall problem. Since your server is on a public IP, turn on the Adaptive Firewall for your SIP services and see if that helps.


(Martin Ohlenburg Schmidt) #5

Thank you for the answers. The mistake cleared up an hour ago. My provider runs its own firewall, but I only got access to its settings after requesting it. Only the standard ports such as 80 etc. were released in this.


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.