Asterisk + FreePBX install failure


(Bob) #1

when i run these commands from this guide (https://computingforgeeks.com/how-to…-debian-linux/) i run into this error.

./install -n --dbuser [user] --dbpass [pass]
root@ubuntu:/usr/src/asterisk-17.6.0/freepbx# sudo ./install -n --dbuser [user] --                                                                                                                                                             dbpass [pass]
Assuming you are Database Root
Checking if SELinux is enabled...Its not (good)!
Reading /etc/asterisk/asterisk.conf...Done
Checking if Asterisk is running and we can talk to it as the 'asterisk' user...Y                                                                                                                                                             es. Determined Asterisk version to be: 17.6.0
Checking if NodeJS is installed and we can get a version from it...Yes. Determin                                                                                                                                                             ed NodeJS version to be: 12.18.3
Preliminary checks done. Starting FreePBX Installation
Checking if this is a new install...No (/etc/freepbx.conf file detected)
Updating tables admin, ampusers, cronmanager, featurecodes, freepbx_log, freepbx                                                                                                                                                             _settings, globals, module_xml, modules, notifications, cron_jobs...Done
Initializing FreePBX Settings
Finished initalizing settings
Copying files (this may take a bit)....
 9363/9363 [============================] 100%
Done
bin is: /var/lib/asterisk/bin
sbin is: /usr/sbin
Finishing up directory processes...Done!
Running variable replacement...Done
Creating missing #include files...Done
Setting up Asterisk Manager Connection...Done
Running through upgrades...
Checking for upgrades..
No further upgrades necessary
Finished upgrades
Setting FreePBX version to 15.0.16.60...Done
Writing out /etc/amportal.conf...Done
Chowning directories...
Taking too long? Customize the chown command, See http://wiki.freepbx.org/displa                                                                                                                                                             y/FOP/FreePBX+Chown+Conf
Setting Permissions...
Setting base permissions...Done
Setting specific permissions...
    0 [>---------------------------]
In Encoding.php line 196:


  Array and string offset access syntax with curly braces is deprecated




chown [-f|--file FILE] [-m|--module MODULE]




In Process.php line 239:


  The command "/usr/sbin/fwconsole chown" failed.


  Exit Code: 255(Unknown error)


  Working directory: /usr/src/asterisk-17.6.0/freepbx


  Output:
  ================




  Error Output:
  ================

im still learning the ropes oflinux and is currently on ubuntu 20.04.

i dont quite understand the reason of this error as its simply trying to chown a directory. Perhaps someone with more experience with FreePBX could share. i havent found a solution that worked so im hoping on someone can share some insight of the appropriate course of action here.

Also maybe share insight into how to get voip working with actual phone number to incoming. I have no experience and have no clue where to even begin. Eg. somenoe dials 555-1234 and it get routed to my server. How does that infrastructure work?


#2

For a beginner, you’ve chosen a difficult path to get FreePBX running.

What are you trying to accomplish (make a phone system for your home or business, learn about phone systems so you can sell them, build a specialty application of which FreePBX would be a part, etc.)?

What are you trying to run it on? A cloud server (whose)? An on-site virtual machine (which platform)? An old PC?

Assuming (based on the format of your example number) that you are in US or Canada, there are hundreds of SIP trunking providers to choose from. Some that offer fairly generous free trials and are IMO suitable for beginners are Telnyx,Twilio and SignalWire.

You can also get gateways that can connect analog or digital phone lines or cellular SIM cards to FreePBX.


(Bob) #3

Thanks for your replay stewart.

i was not aware that a path i chosen was a difficult path.

what i am trying to accomplish is currently education and personal use. I dont think ill be commercially selling this as a service until i can figure out how to map phone numbers with it.

Essentially im trying to have a phone number someone can call and it gets routed through my voip servers.

this is currently running on my pi4 4gb model on ubuntu 20.04 64bit

i reside in CANADA and i do have a few numbers from voip.ms. they are a great company but i just prefer to be in control of things.

Could you expand on this?


#4

Ubuntu 20.04 deploys the currently supported PHP (7.4 I believe) , unfortunately FreePBX as yet can’t run under that , choices are, downgrade to Ubuntu 18.04 (or simple mindedly just use the distro) a little trickier though you can replace your PHP with the no longer supported PHP5.6.


#5

If you just want FreePBX on a Pi, see
http://www.raspberry-asterisk.org/
If you need to run other major software on the same Pi, please describe your application and constraints.

In Canada, I believe that the VoIP carriers (Fibernetics, Iristel, ISP Telecom) don’t deal directly with small customers so you can’t avoid middlemen such as VoIP.ms. Some of these middlemen are wholly or partly owned by carriers, e.g. I believe Fongo is owned by Fibernetics, which may result in better reliability or support, but I don’t know enough about the Canada system to make a meaningful recommendation.

For a lab system (where traffic is low), consider SignalWire. Numbers are only $0.20/mo., though you pay per minute for every call in or out, and pay per message for each SMS sent or MMS sent or received.

For gateways, see (for example)
http://www.raspberry-asterisk.org/documentation/gsm-voip-gateway-with-chan_dongle/
or
http://www.grandstream.com/products/gateways-and-atas/analog-telephone-adaptors/product/ht813
If interested, ask a more specific question.