Asterisk Follow Me / Caller ID, Wrong Caller ID


I’m using for a while the follow me feature going to my cell phone but on my cell phone the caller id is my office phone number. Is there a way to display the real Caller ID and even better, have a prefix such as FWD:555-555-5555 ?



Does your VoIP provider lets you provide your own caller ID information?

I am dealing with 3 providers and for at least one of them it’s a pain to get them to let you send your own caller ID information and by default you cannot…

Good luck!


Hello, yeah I think so, we’re having our own Asterisk connected to


This is one of the provider I use and they do allow setting your own caller ID…

Did you force a specific caller ID on your trunk, your route, in the follow-me or in the main account or sub-account you created on their site?

By the way, the place where you would want to put that "FWD: " is in the “CID Name Prefix” of the follow-me I believe…

Have a nice day!


I’ll have to ask one of my team member to take a look, I was hoping there was a quick way to do it through asterisk.

Stay tuned.

The first 3 (trunk, route, follow-me) you can check on the FreePBX/Asterisk box…

As for your VoIP provider (s)he will have to check under:

Account settings, General, CallerID Number

if it’s the main account.

If it’s a sub-account it’s more or less in the middle of the settings and it’s under:

Sub-accounts, Manage Sub-account, Edit, CallerID Number.

Good luck!



I took a look, you were right there was a forced ID in, I removed it. Also, I did some screenshot in case it would help. (drop box with www and https) /sh/99hrnaw0e2r81ew/AADYHE65Gm6nFh9cBZQzNGW-a?dl=0

Removing the forced ID hasn’t worked, I also added a prefix but the prefix happened on my office phone (ext 102) and but on my cell phone.

Thanks a lot

Bonjour Raphael!
(Hi Raphael!)

Sorry, I was not notified that you had replied…

From the screenshot I can see that it was in the main account so I assume this is what you are using (these can be set separetaly on a per account/sub-account basis and personally I do not use the main account but only sub-accounts)…

You are using a much older version of FreePBX than me it seems so I am having a harder time finding what I want to see but one thing I would have liked to look at is the outbound routes used (you posted only the inbound route as far as I can see).

(Your trunk is used by two outbound routes by the way…)

On my version of FreePBX the route is not supposed to override the follow-me caller ID but maybe on yours it does…

If all else fails and you don’t see where your office phone number is set I would be tempted to go into what is most likely the “/etc/asterisk” folder and grep for your office phone number to see in which file it is…

The name of the file and a few lines of context would probably give a good clue as to where it is set…

Bonne chance et bonne journée!
(Good luck and have a nice day!)



Thanks for your reply.

In the config file there is few numbers, in this variable: OUTCID_1 to OUTCID_4. However, the format of the phone numbers are 5554443333 not like displayed on my cell phone 1 555-444-3333

I know we have an old asterisk, I’m planning to reinstall everything but my guy who take care of it being outside and me being bored to have the wrong cid I thought I would give a try lol.


These are probably in extensions_additional.conf and are most likely your trunks.

I am not sure I would trust your cell phone to report exactly what is sent, maybe it is adding the 1 (or +1).

I think I would replace the caller ID of your trunks (those multiple OUTCID_? entries suggest you have more than one) with something like 514-555-1212 or 450-555-1212 as a test to see if that’s where that phone number you see on your cell phone is picked up.

If you still see your office number after replacing those phone numbers with that fake one it means we have to look elsewhere…

Just to make sure we understand each other correctly if you call with a phone whose number is 514-555-1234 your extension with a follow-me which then forwards everything to 450-555-4321 you see as caller ID 514-555-5555 which is your office phone number, right?

Do you have FXOs which are connected to your office phone system or is this solely using Maybe it’s a routing issue if you have analog trunks which are used instead of

What’s in it those others trunks? Could you be using something else in there besides and this is what ends up being used…

I had sooooooooooooo much fun setting up a new trunk yesterday because I had duplicated a trunk and did not realize I had left it deactivated (a duplicated trunk is deactivated by default) so it was not using it…

(That provider had just recently allowed me to send my own caller ID so I was getting rid of the configuration I had setted up when I was forced to use specific caller IDs.)

I realized something was very wrong with my trunk by SSHing into my box, doing a “asterisk -rvvvv” and then a “sip set debug on”…

When I saw that there was absolutely no attempt to access my trunk I looked at it more closely and saw it was deactivated…

Bonne chance!


Hey Nick

No we’re just using I removed all ID in the conf file, restarted it and still get the same number on my cell phone. I’m clueless now. The only place I still see the number is in the Outbound CallerID in the SIP Trunk.

You’re too voip geek for me, I’m an old sysadmin and knows a little bit of it, but looks like I’ll wait the my guy LoL


Hi Raphael!

If you change that outbound caller ID in the SIP trunk temporarily, does it change the caller ID you receive?

If not, it’s not that…

Are you absolutely sure that you are using the main SIP account on and not a sub-account? Sub-accounts have their own caller ID information…

My main account is configured but it’s not what I use, I use solely sub-accounts maybe it’s the case for you too…

When you log on it shows you which account and sub-account(s) you have registered.

Is the main account registered?

In my case I see something like this (it’s actually a bit more complex than that as I have a couple of ATAs (phone adapters) in addition to my PBX and I also have SIP clients on my cell phone (long story…)):

Main Account Registration Status:

Account Server State
999999 – No registration found

Sub Account Registration Status:
Account Server State
999999_pbx Registered

In my trunk I have something like this:

PEER Details:

Register String: 999999_pbx:[email protected]:5060

(for me had the best ping time…)

That 999999_pbx is the name of my sub-account (actually it’s not 999999 but you get the idea…).

Since you are a sysadmin you know as well as I do that there is no magic, there only a configuration hidden somewhere which we are not seeing…

You might also want to chat with tech support, if it’s something on their side I am sure they will find it. They have always been very helpful when I needed help…

It “smells” like it could still be an hidden config somewhere in… My guess is that you are using a sub-account…

Good luck!



You were right. I thought it was the main account but not, sorry about that, it works now :confused:

The only thing is that the prefix isn’t following.

Bonjour Raphael!
(Hi Raphael!)

Pas de problème…
(No problem…)

Sorry for the delayed reply…

OK, first thing to check is if the phone number you are calling (possibly your cell phone) has the number of the phone you are calling from in its contacts/phone book…

From personal experience I know a lot of cell phones and even normal phones override the caller ID information with their own when the calling number is in their contacts/phone book…

That’s the first thing I would check…

Let me know how it turns out…

Bonne chance!
(Good luck!)


Yeah the phone number is right but no prefix, I would bet for Telus rewriting.

Thanks for all your help buddy

Bonjour Raphael!
(Hi Raphael!)

Please take a look at this: CID Name Prefix is not working in Ring Group Module

What is said there is no longer fully true, it might have been at the time but the

“Yes that is because FreePBX only does the prefix in ring groups and
follow me and such to local phones. That is what we all keep telling
you. Because in the past lots of carriers would actually reject the
call if you tried to send a Caller ID Name so we put in logic in FreePBX
to not prepend the Caller ID for external calls.”

said by tonyclewis (Tony Lewis) on February 12th appears to be still true as far as the prefix not being added for external calls…

On Fido/Rogers I definitely receive the caller name I set for my extension (I set it to “allo” and my phone number (formatted as described in the help) and it worked but it definitely looks like the part about the prefix not being sent for external calls is still true…

(I checked for an internal one and it definitely works…)

He also said this:

“yes but the name is handled by your carrier. They ignore any name you
send and put their own in. CID prepend only works for internal phones
not external phones like cell phones.”

which might be true with some providers but Fido/Rogers definitely use what I send…

So now you are left with two choices (assuming Telus passes the caller ID name information you set when it’s not a prefix) either:

  • try to find where this removal of caller id prefix information for external call is done and modify it so it is kept…


  • try to get the FreePBX devs to reconsider their decision…

  • Use the “Call Confirmation” feature (if your version has it) and playback an announcement saying it’s a forward to the person being called…

As for the help, “de rien!”…

Bonne chance et bonne journée!
(Good luck and have a nice day!)