FreePBX | Register | Issues | Wiki | Portal | Support

Asterisk DPMA on EPM - module not loaded


(Adolfo) #1

Did a clean install of FreePBX 14 (Asterisk 13), and i keep getting an error when trying to enable USE DPMA in EPM. It says “Asterisk DPMA (res_digium_phone.so) module is not loaded/licensed.”
I’ve licensed it in Digum Addons, it shows it’s installed and registered.
Digium Phone module is uninstalled since I understand that causes a conflict.
Upgraded EPM and restapps to edge.
Looked through https://wiki.freepbx.org/display/FPG/EPM-Use+DPMA+for+Digium+Phones

I’m lost… any ideas?


(Chris Dolese) #2

yum install asterisk13-res_digium_phone.x86_64


(Adolfo) #3

Package asterisk13-res_digium_phone-3.5.0-1.sng7.x86_64 already installed and latest version
Nothing to do


(Kapil Gupta) #4

Hi @adolfoc Are you using FreePBX ISO or installing FreePBX on custom OS ?

Error means either DPMA module is not installed or not licensed to use. FreePBX ISO installation comes with default DPMA license but for custom OS installation , license for Asterisk DPMA needs to installed.
You can manually try to load module into asterisk cli and check the status.

asterisk -rvvv

CLI -> # asterisk -rx “module load res_digium_phone.so”

#CLI > digium_phones license status


(Adolfo) #5

This is a FreePBX ISO. For some reason when I try to run asterisk -rx “module load res_digium_phone.so”
I get:

Unable to load module res_digium_phone.so
Command ‘module load res_digium_phone.so’ failed.


(Adolfo) #6

So I started over. Wiped my install. Started fresh with ISO SNG7-PBX-64bit-1805-2a.
Only ran module updates (fwconsole ma upgradeall), did not run firmware updates (yum update).
Also did not register the DPMA in Digium Addons this time around.
And still getting the “Asterisk res_digium_phone.so module is not loaded/licensed. Please refer to DPMA management configuration for license configuration”
Is there something wrong with this ISO or bug not fixed in firmware updates?


(Adolfo) #7

ok i think I’m closer… I opened asterisk CLI in verbose mode and when I ran “module load res_digium_phone.so” it told me:
[2019-05-30 23:26:41] ERROR[19238]: res_digium_phone.c:483 load_full_components: Failed to load phone config

what phone config is it referring to?


(Adolfo) #8

So I found /etc/asterisk/res_digium_phone.conf was missing… (why?!)… copied it from another PBX i had and seemed like just pointers to other .conf files.
Then ran asterisk -rx “module load res_digium_phone.so”
and it finally loaded successfully.
Then I was able to go to EPM and toggle “Use DPMA” and it worked.
whew


(D E) #9

dasdasddddd

Currently receiving the (seemingly?) conflicting messages from my installation. Have checked and it’s still licensed.
One oddity that I keep running up against as I try to debug the various ways DPMA and/or EPM do not seem to be working for me at the moment is that sometimes if I reboot the phone in order to change tack slightly, when the prompt appears to choose which extension I want to configure as, the extension I was JUST using is no longer a valid option.


(D E) #10

Checked the CLI with “module load res_digium_phone.so” and it says
res_digium_phone.c:483 load_full_components: Failed to load phone config


(D E) #11

So reinstalling Digium Phones Config seems to have reinstated the phone config, but the license despite having previously worked and despite me using the exact same key just shows:
dasdasdasdasdsadasdasdsa
I have tried a fwconsole reload which didn’t help. Now trying a fwconsole restart in case that does help.
Yes. It did help.
Now to see if EPM or DPMA will play ball?!

EDIT

It’s bizarre. So removing and reinstalling the Asterisk DPMA files seems to have restored the ‘presence’ part of the FreePBX DPMA Web GUI module which worked at one point then inexplicably stopped working:


but now the phone is unable to find an mDNS server?!

honestly it’s like playing whack the rat.

EDIT2 A full hardware restart of the entire server brought back the mDNS server, but again, there’s only ONE extension to choose from in the “select your name and extension” which is the ‘TEST’ extension. if I disable the filter, the extension I want to choose is shown again. I’m not 100%, but I have a feeling that preference persists across uninstall/reinstalls of Digium Phones Admin and factory resets of the D50