Asterisk doesn't get the DID from the ISDN line

asterisk
dahdi
Tags: #<Tag:0x00007f7024d1a218> #<Tag:0x00007f7024d1a0b0>

(Kai Herlemann) #1

Hi everyone,

we use Asterisk in our department to route the calls we receive on a DID to a specific cell phone number, depending on time and date (follow me & time conditions modules). This works very well. Unfortunately we’re required to use ISDN/DAHDI, because the telecommunications department uses currently a proprietary VoIP solution which is not compatible with Asterisk (HFA protocol from Unify). This is an outdated solution, but at the moment we need to use it.
We would like to add a second phone number to our system, it has a seperate ISDN line. However, if I enter the DID in the field “DID number” of the “inbound routes” module to distingush which DID was called, no call at all is forwarded to the destination. It seems that Asterisk just does not get the called DID from the ISDN lines/the PBX (see attached logfull.tgz (109,6 KB)).
I need to enter no DID at all. So “any” DID/any call is forwarded to the same destination, doesn’t matter which DID was called.

Is there any solution for this problem?
Any help is appreciated.

Thanks in advance,
Kai


#2

You will have to define your “isdn” flavor, is it BRI or PRI?

Both protocols supply the DID, PRI’s generally can use the [from-did-direct] context

;-------------------------------------------------------------------------------                                      
; from-did-direct:
;
; forces ext-findmefollow to take precedence over ext-local. Also exposed to                                          
; the public side to allow an extension number to be used as an external DID                                          
; without requiring inbound routes to be created, common in many PRI installations                                    
; where the last 4 digits are used as the extnension and DIDs are delivered in                                        
; 4 digit formats.
;
[from-did-direct]
include => ext-findmefollow
include => ext-local

So let us know how many LSD (Least Significant Digits) the Vendor is sending you.


(Kai Herlemann) #3

Hi, thank you,
it’s BRI.
The DID numbers are 4 digits long, but 1 LSD would be already enough, because the last number isn’t the same.
However, as far as I see, no DID at all is supplied :thinking:


#4

Can we assume that you are not in the US (there are probably something between 200 and 300 still extant BRI’s here :wink: )
?


(Kai Herlemann) #5

Hi, yes, I’m in Germany :wink:
We use FreePBX distro and the most recent packages (Asterisk 16.11.1 et al), most recent FreePBX modules, release 15.


#6

And your ISDN interface hardware is ? (hopefully not Cologne :wink: )


(Kai Herlemann) #7

It’s a B410P from Sangoma/Digium.


#8

I will bow out here, Perhaps as our sponsor here is ‘Sangoma’, they likely have a resource for you. Good Luck.


(Kai Herlemann) #9

ok, thanks :slight_smile:


(Kai Herlemann) #10

One last question, you think (like me), it’s not an Asterisk problem?
So there must be changed something on the card (settings or jumper) or the PBX system from our telecommunications department doesn’t support to supply the DID to ISDN lines?

By the way, we also have a card which runs with the mISDN module. But it seems like it doesn’t work anymore with Asterisk (too old), so we bought this B410p card from Digium/Sangoma.


#11

Yes and No, WANPIPE is not DAHDI and DAHDI is not directly integral with Asterisk, you need to set the Sangoma card to properly behave in a Dahdi fashion when you configure it. Further, you then need the Sangoma setup to recognize and provision the signalling from your provider, so passing the DID to DAHDI and thus ultimately to Asterisk.


#12

(Also seems like B410P is also no longer supported :wink: )


(system) closed #13

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.