Asterisk Crashing and Restarting - 'yum update' broken my system?


Over the past few days Asterisk has started to randomly restart by itself, dropping all calls and registrations.

I’ve looked at the full log file and I do not see any errors or warnings in the run up before the restart.

The system was fully updated with system updates (yum update) and module updates (fwconsole ma upgradeall) the night before this happened so I’m not sure if this is related to the crashing or just a coincidence.

I’m not sure how to investigate this so hoping someone can help me?

I know my way around FreePBX and have a understanding of Asterisk but I’m at a loss on how to troubleshoot this issue or even provide logs/information that you require in order to help!

After each crash, a /tmp/core.* file is created. I have uploaded this and the full log file which I can provide if need be. (I didnt want to post the links in case it contains sensitive information)


I believe these issues have been caused the the recent ‘Yum update’ as the first crash was about 40 minutes after.

I’ve just tried ‘yum update’ again in case there are more new updates available but there are no new updates available.


Just to update:

This is a busy system so I cleaned up my asteriskcdrdb tables by archiving everything older than 1st Jan 2019 to another table (I will move these off the box eventually). Asteriskcdrdb.cel had over 150,000,000 records and it was extremely slow to open so I wondered if this was causing asterisk to hang and crash. I don’t require the asteriskcdrdb.cel data so decided to truncate the CEL table.

After reading, Providing Great Debug - Backtraces (Segfaults/Core Dumps/Asterisk Crashing), I ran the following two commands on my system:

# Only for FreePBX Distro 7!
yum install -y sangoma-devel
debuginfo- install --enablerepo=centos7-debuginfo asterisk16

Now, if/when I have another crash, I should run the following command which should generate a backtrace which can help explain what caused the crash.

/var/lib/asterisk/scripts/ast_coredumper /tmp/ [name of the core file ]

However, I believe I want/need asterisk to be running with the BETTER_BACKTRACES Build Option - How do I achieve this?

It was my understanding from the below topic that I just needed to run the two commands above from the Wiki I referenced above. I have rebooted the server since running those commands.

Lastly, I checked ‘yum update’ again and there were 4 new updates available (asterisk16-res_digium_phone, libpri, libpri-devel and sangoma-pbx) which I have installed.

I then rebooted the system again. That was just over 10 hours ago and so far no crash which is positive.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.