Asterisk constantly crashing


#41

sarcasm?


#42

No, I am just not a particular believer in ‘coincidences’ being unrelated.

Did you check your memory’s integrity yet ? It would be one thing to check off the list .


#43

can’t… see post above


#44

Boot a “recovery iso” that can bypass uefi perhaps ? (it might be a bios thing needed . . .)


#45

at this point I’m installing the ISO on a usb stick and I’m going to reload from scratch and restore a backup.


#46

On fresh installs, I always add a ‘root kit’ detector as soon as possible, you never know . . .


(Canada) #47

I had this exact same issue today, however on another platform. My client is running FreePBX 15 on Sangoma Linux 7 and this morning I got the call the phones were down. The only way I could get the PBX back online was to run yum erase asterisk16-res_digium_phone which disabled the DPMA module. When I tried to re-install the module, asterisk again started to crash every few seconds with the same segfault error. Thankfully I am able run this PBX without the Digium Module and failing finding a solution, I may have to do a fresh install as well.


(Lorne Gaetz) #48

(Canada) #49

Thank you for informing us about the downgrade. This resolved the issue on my PBX as well. From an uninstalled state, I ran yum install asterisk16-res_digium_phone which installed version 3.6.5.1 and then without an asterisk restart I immediately ran yum downgrade asterisk16-res_digium_phone which installed version 3.6.3.2 then finally ran fwconsole reload

This restored the Digium Module to a good working state with no segfault crashes.


#50

Seeing the same issue here on a Asterisk 13 system.

On Monday evening (9/20), all packages were updated (fwconsole updateall and yum update):
—> Package asterisk13-res_digium_phone.x86_64 0:3.6.3-2.sng7 will be updated
—> Package asterisk13-res_digium_phone.x86_64 0:3.6.5-1.sng7 will be an update

Starting this morning, roughly 32 hours after upgrade, we started seeing problems, and I can see asterisk crashes when I see DPMA messages in the console. Looking back at monitoring, I can see this was a problem since the upgrade.

Downgrading res_digium_phone seems to have solved the issue.

yum downgrade asterisk13-res_digium_phone
—> Package asterisk13-res_digium_phone.x86_64 0:3.6.3-2.sng7 will be a downgrade
—> Package asterisk13-res_digium_phone.x86_64 0:3.6.5-1.sng7 will be erased

I then had to restart the system as I couldn’t get asterisk to restart cleanly.