Asterisk 1.6, SpanDSP, app_fax and FreePBX

Ok, I have finally decided to roll my own load with CentOS 5.2, Asterisk 1.6 and FreePBX 2.5 - so far so good - it is working and seems stable (I am also revising the CentOS 5.1 install guide - it is wrong in many places - I will post the correct version when I have everything working).

I also went over to VoIPInfo and used the information there to compile SpanDSP support for 1.6 so that when I ran make menuselect from Asterisk, app_fax was shown as a valid option and was checked - when it is running, I get the following output:

core show applications like fax
-= Matching Asterisk Applications =-
ReceiveFAX: Receive a FAX
SendFAX: Send a FAX
-= 2 Applications Matching =-

So I think I have done it right - but here is the question(s):

  1. The only fax detection types are NVFax and Zaptel - Newmans is not installed, and it is using Dahdi - is the correct option Zaptel?

  2. I know the code for NVFax worked GREAT with 1.4 - we use it everywhere - will the scripts for FAX reception need to be modified for Asterisk 1.6, and if so, where is the script (agi I assume) that is called when a FAX is received - if it needs to be modified, I would be happy to do it - I juse need to know where it is.

Thanks for the help - I am working on this constantly and will post a working guide and updates when I make progress - It feels SO GOOD to break free from pre-controlled distro’s and finally install and configure it the way I want - and to be able to use current versions of everything!

More to come!


I’m going though the exact same thing with and 2.5.1 on Debian 5, did you ever find out what needs to be done to enable NVFAX or similar fax application?


I’ll be interetested to get NVFAX compiling properly with Asterisk 1.6

I’ll keep watching here :slight_smile:

I have Asterisk running with a the new version of nvfaxdetect that hasn’t been released yet. I am running on Centos. We actually were able to work something out with the developer for him to assist us with it. It should be released sometime this summer.

Please keep us posted! I’m ripping my hair out trying to get this to work!

I am running 1.4 on CentOS (freePBX 2.7) and have not been able to get it going.