Are findme/followme and the "intercom" function on Digium phones not mutually compatible?


(D E) #1

I’ve found that if I try to use the contacts>show>“intercom” option from my Digium D50s, it fails if I try to call an extension with findme/followme enabled. If I disable it, it works.

The OTHER method of intercom dialling using a custom alert “auto-answer” seems to work regardless of whether findme/followme is enabled.

Log for the two different calls:- WORKS | DOESN’T WORK

The difference seems to be with findme/followme disabled, the dial string looks like this:

[2019-07-24 13:55:47] VERBOSE[5739][C-00000093] pbx.c: Executing [*8026@ext-intercom:15] Set("PJSIP/22-000000a4", "_ALERTINFO=Ring Answer") in new stack

and without findme/followme enabled:,

[2019-07-24 13:58:43] VERBOSE[6812][C-00000095] pbx.c: Executing [s@macro-dial:17] ExecIf("PJSIP/22-000000a9", "0?Set(HASH(__SIPHEADERS,Alert-Info)=Normal;volume=)") in new stack

just wondered if anyone had come across this?


(Tom Ray) #2

Your two excerpts are not really telling of anything. You only end up in ext-intercom if *80 is being used to dial the call. Macro-dial is used for pretty much all calls. In order for Intercom to work you need to tell the phone to Auto Answer.

you need to show whole calls not just a couple lines so we can really see what is happening.


(D E) #3

Hi Tom, thanks - by whole calls, do you mean more than the logs I posted at the two pastebin links in my original post? That’s fine if so, I’ll have a dig around in my logs to see if I can find more info.

If I could just clarify, perhaps?

I HAVE told the phones to Auto Answer as you suggest, and indeed using the intercom function on the digium phones works just great IF ‘follow me’ is NOT enabled on the extension. If it IS enabled, it doesn’t work.

At no point am I physically dialling *80, I’m using the softkey “intercom” from the D50 contacts.


(Tom Ray) #4

Yes, totally those. The ones I missed. I’ll have to look at them.


(Tom Ray) #5

OK so if you want it to use intercom in followme then you need to have *8026 and *8022 so that it will trigger the ext-intercom context. If you are going into the phone and hitting an Intercom option that lets you dial an extension via Intercom it’s because the phone has *80 in its prefix settings for that. It’s prefixing the *80 for you.

The only way to end up in the ext-intercom context when dialing an extension is it sees *80 as the prefix of the extension. Otherwise it doesn’t execute that context.


(D E) #6

Hi Tom. Thanks. Thanks for taking the time. I appreciate it.

I’m not sure I understand where it’s going wrong, however. I’ve read your post four times and whilst I understand what you’ve written, I don’t see why enabling ‘followme’ on an extension strips the *80 the phone is prefixing. Because that’s what I think I’ve understood must be happening?

I use the intercom button with no followme and *80 is retained and the intercom works
I use the intercom button WITH followme and *80 is stripped

This isn’t a big deal for me, I’m genuinely 80% academically/technically curious and 20% would find it useful if the two features could coexist.

:slight_smile: :slight_smile: Thanks!


(D E) #7

oo oo - forgot to say - I THINK (will need to check tomorrow when back in the office) that if I physically type in *8026 on an extension with FollowMe enabled, it works. It seems to be something about the phone’s softkey and FollowMe.


(Tom Ray) #8

It doesn’t. I never said it did. I said if you are pressing a key on your phone that does Intercom and all you have to do is enter the extension number, the phone is prefixing *80. Perhaps I am confused.

Are you trying to Intercom an extension and have the FollowMe of that extension still work? Or are you trying to have a FollowMe destination answer as an Intercom call?


(D E) #9

Possibly? The D50 has an intercom softkey you access via the contacts page. You get three options:
voicemail, intercom and monitor.

This. But as I said, it’s really not a big deal, I’m just curious I guess about why it doesn’t work with FollowMe enabled. Because if I use the intercom module to setup an intercom rapid dial THAT works with FollowMe enabled. And the intercom softkey works so long as FollowMe is not enabled. :slight_smile:
Anyway - this really isn’t important, so let’s not lose any sleep over it!! :slight_smile: :slight_smile:


(system) closed #10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.