Apply Config Failing in UI Version

Hello All,

I am testing FreePBX 17 on a Raspberry P 4+ running the latest Raspian.
It’s pretty amazing and great work indeed.
FreeBPX 17 was running very smoothly for a couple of weeks… until I tried to add a new extension today.

When I tried to Apply Config in the UI, and error was shown:
Unknown Error. Please Run: fwconsole reload --verbose

Upon running fwconsole reload --verbose I see the following error message and stack trace:

In extensions.class.php line 199:

died in splice macro-dial-one s

Exception trace:
  at /var/www/html/admin/libraries/extensions.class.php:199
 extensions->splice() at /var/www/html/admin/modules/ivr/
 ivr_get_config() at /var/www/html/admin/libraries/BMO/DialplanHooks.class.php:97
 FreePBX\DialplanHooks->processHooks() at /var/www/html/admin/libraries/Console/Reload.class.php:320
 FreePBX\Console\Command\Reload->reload() at /var/www/html/admin/libraries/Console/Reload.class.php:92
 FreePBX\Console\Command\Reload->execute() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Command/Command.php:312
 Symfony\Component\Console\Command\Command->run() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:1022
 Symfony\Component\Console\Application->doRunCommand() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:314
 Symfony\Component\Console\Application->doRun() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:168
 Symfony\Component\Console\Application->run() at /var/lib/asterisk/bin/fwconsole:163

I thought I report the error and look forward to upcoming releases.


I’m on and ran into the same thing. I’ve had no problems and have made no changes for maybe a week or so. That being said I am VERY bad with the apply button so maybe I had something queued up for a bit. I added a SIP extension, went to apply the config and received the same error.

The problem seems to be with (or related to) IVR. If it’s an option for you - I was able to get going again by removing or disabling the IVR application. I tried a remove and then a reinstall but that did not work. I also tried installing from edge but it didn’t look like that was available.

You need to consider this ‘alpha’ in other words it might not work yet

According to FreePBX it’s now beta. (sorry can’t post the source as a new user).

Wow. Thanks so much for the replies. rickrrr I think you were spot on.
For anyone else interested I ran:

sudo fwconsole moduleadmin disable ivr
sudo fwconsole reload --verbose

This seemed to clear all of the error.
I also had tried a re-install on top of the current install, but don’t know the “remove” procedure…
What’s the cmd to remove before re-installing?

Also, if anyone is interested in the hoops I had to jump through to get FreePBX working on a Pi, let me know where I can post the cmd procedures that worked for me.

Thanks so much again,

fwconsole moduleadmin uninstall ivr

should uninstall for you - but I did try an uninstall/reinstall via the UI and it had no affect. Give it a shot though - more data points can’t hurt!



You need to consider this ‘alpha beta’ in other words it might not work yet :rofl:

I was having the same problem; the latest framework update fixed it for me.

Awesome - thanks for the update!

Yes indeed. Thanks for that update.
What is the best way to update the FreePBX Framework?
Is it just a matter of downloading, expanding, and installing over an existing install using the latest tar file?
Or is there an uninstall procedure that should be run first?

Thanks again,

The same way you update any module, from the Module Admin page or using fwconsole ma