Apply config causes drop SIP calls

When i “Apply config” , internal and external SIP calls stopping sounds. SIP phone shows are still connected, but callers cant hear each other.
Cant find any topic about this problem.

PBX Firmware: 6.12.65-27
PBX Service Pack:

I tried to install clean, latest FREEPBX 13 and created 2 extensions. Same problem appearing.

I researched the behavior of the system:
On “apply config” or “amportal a r” - asterisk crashes with segmentation fault

kernel: asterisk[2824]: segfault at 7ffb00000009 ip 00007ffb9a00cf72 sp 00007ffb2e9456c0 error 4 in[7ffb99f97000+18a000]

I got backtrace.txt , but I can not figure out what’s going on

Someone have any ideas?

Since the software from your original version to your new version is completely different, I’d start with something like “ramtest86”. Run through your RAM and see what’s failing.

Since the only commonality from where you were to where you are is hardware, I’d respectfully suggest that the software may not be the problem.

Ram is normal, otherwise, other virtual machines on this host crashes at random time . But we have crash when a specific event happening.(only amportal reload)
I tested situation when, there are no SIP peer connected to server. Result - no crashes, without workload.
Is it possible that some sip peers causes problems?
We have 80 cisco SPA phones , 10 Thompson phones , and 5 Astra phones. Including external(real ip) and internal connections

OK, just so we’re clear.

This, in my experience, is either a failure in something you’ve added to the system or a RAM error. I’ve personally never seen a server fail like this for something I’ve added to the system, but I have seen plenty of segfaults from bad RAM.

If it isn’t hardware, then I can’t help you. When I see this in my servers, it’s bad hardware.

Hmm, it was very simple. Upgrading asterisk to latest stable version 13.9.1 solved the problem