FreePBX | Register | Issues | Wiki | Portal | Support

APC UPS Management Card and FreePBX SysAdmin UPS Utility


(John Jarrett) #1

I just installed an APC Network Management Card in my UPS and I think I have set the SNMP settings correctly in the card’s web interface. Public read with host 0.0.0.0 should do it.

In my FreePBX, 14.0.13.4, under the UPS settings, in Sys Admin, I have tried almost every combination using Ethernet, setting Ethernet Cable, SmartUPS, adding the UPS IP address of 192.168.0.25 with port :161, I tried, the default port that is “suggested” or shown in the hint, and also tried port :6547 and port :3052, which the APC network shutdown software uses with the UPS.

Using apcaccess status I always see, Status; ComLost.

Does anyone have any experience with FreePBX and the APC Network Management card? Or, any hints, things to try, etc?

Thanks in advance for any help. I know I am missing something pretty simple.

John


(Itzik) #2

Never connected one. Have you looked at the documentation?
https://wiki.freepbx.org/display/F2/System+Admin+-+UPS+Server


(Tony Nichols) #3

This the config for mine…

apcupsd.conf v1.1

UPSCABLE ether
UPSTYPE pcnet
LOCKFILE /var/lock
DEVICE 192.168.1.20:username:password
UPSCLASS standalone
UPSMODE disable
SENSITIVITY L


(John Jarrett) #4

@PitzKey, yes I did.

@alscorp… thank you for the info. I will try later today. I did not know that a username and password might be needed. I was thinking I needed just a port number.

John


(Tony Nichols) #5

I believe the default is device and password is apc, however you can make your own inside the administration section of the management page.


(John Jarrett) #6

@ alsicorp… Tony, thank-you for all the info. No matter what I try, I still get COMMLOST under status when I do an apcaccess status from the CLI.

Would you be so kind as to post the results of an apcaccess status?

In some threads using SNMP as UPS Type, (you have to manually edit the conf file as FreePBX doesn’t allow that in the GUI), it shows, when allegedly working, this same status of no communication.

Thanks!!

John


(Tony Nichols) #7

[root@pbx ~]# apcaccess status
APC : 001,050,1226
DATE : 2019-07-11 14:04:32 -0400
HOSTNAME : pbx
VERSION : 3.14.10 (13 September 2011) redhat
UPSNAME : pbx
CABLE : Ethernet Link
DRIVER : PCNET UPS Driver
UPSMODE : Stand Alone
STARTTIME: 2019-07-11 11:14:18 -0400
MODEL : Smart-UPS 3000 RM
STATUS : ONLINE
LINEV : 122.4 Volts
LOADPCT : 21.4 Percent Load Capacity
BCHARGE : 100.0 Percent
TIMELEFT : 37.0 Minutes
MBATTCHG : 10 Percent
MINTIMEL : 5 Minutes
MAXTIME : 0 Seconds
MAXLINEV : 122.4 Volts
MINLINEV : 120.9 Volts
OUTPUTV : 122.4 Volts
SENSE : Low
DWAKE : 000 Seconds
DSHUTD : 090 Seconds
DLOWBATT : 02 Minutes
LOTRANS : 106.0 Volts
HITRANS : 130.0 Volts
RETPCT : 000.0 Percent
ITEMP : 28.3 C Internal
ALARMDEL : 5 seconds
BATTV : 55.1 Volts
LINEFREQ : 60.0 Hz
LASTXFER : Unacceptable line voltage changes
NUMXFERS : 0
TONBATT : 0 seconds
CUMONBATT: 0 seconds
XOFFBATT : N/A
SELFTEST : NO
STESTI : OFF
STATFLAG : 0x07000008 Status Flag
REG1 : 0x00 Register 1
REG2 : 0x00 Register 2
REG3 : 0x00 Register 3
MANDATE : 07/25/05
SERIALNO : JS0531001520
BATTDATE : 05/02/16
NOMOUTV : 120 Volts
NOMBATTV : 48.0 Volts
EXTBATTS : 0
FIRMWARE : 666.6.D
END APC : 2019-07-11 14:20:14 -0400

Hope this helps


(John Jarrett) #8

Thanks so much and yes it does help… I have something set wrong in my card… fat fingered a password or something!

John


(John Jarrett) #9

Alrighty, if anyone is interested, I got it!
The password is actually the APC Powerchute authentication phrase and one must add your FreePBX IP to the Powerchute clients in the UPS. Lastly, the default passphrase is “admin user phrase” and white space is not universally liked. I changed the passphrase using at least 16 characters and used ‘-’ the dash or minus sign.

Thanks for the help Tony!

John


(system) closed #10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.