Apache misconfiguration?

Hello, I have just completed the installation of freepbx on a hand-built system, based on Ubuntu 12.04. It is running on a virtual machine, and I can’t upload a pre-built ISO.

I have followed the instructions at


till the end, no issues reported, no weird messages.
Tried to connect to the GUI, at http://mypublicIP/admin, I receive a 404 Not found message.

If I try to connect to http://mypublicIP I land on the It works! page, so I am assuming that Apache is working fine, and it is only an issue of configuration.
I have checked /var/www/freepbx, everything seems to be in place.

I am sure it is something stupid I have overlooked while configuring Apache, but it is not my speciality, and I wouldn’t know where to fiddle.

Anyone can give me a hand in sorting this out please?

Thanks in advance.

Check that your document root for apache2 is /var/www/html in your apache2 sites, /etc/apache2/sites* by default it might be /var/www in debian like machines, and a quick look indicates that your tutorial site missed that bit.

But on looking again I note that the tutorial has

./install_amp --username=asteriskuser --password=$ASTERISK_DB_PW --webroot /var/www/freepbx

which also seems peculiar to me also. . . but recent changes to the install script were intended to make installation on non redhat like boxes were made to fix where the DocumentRoot should be. look in /var/www/freepbx and see if that is there and then try



dicko, thanks for the hint.

Tried http://mybox/freepbx/admin, and managed to get in, and everything seems to work fine.

The only thing that is still off is the User Panel button, when I press it, I still get 404.

By using chrome I’ve been able to analyze the code,and I can see the problem is that it points to http://mybox/recordings, rather than http://mybox/freepbx/recordings

I edited the button in chrome, and once I change it to point to /freepbx/recordings it works fine, but obviously I can’t make it stick outside the session.

Would this affect overall functionality of the system, or is it something I can somehow work around?

Where can I go and edit it to change it once & for all?

Seems that all the links to user panel are pointing to the wrong place, the user login button on the main landing page has the same problem, not just the one in the Admin Dashboard

I think the tutorial has a typo. Do it over with /var/www/ as the web root, not /var/wwwl/freepbx

I have saved an image, should be easy enough just to redo freebpx installation

That is not a typo. Thats an example, it’s pointing out the fact that you don’t have to use the standard directories. You can use whatever you want.

it’s not very clear in the tutorial. If this was design intent, thought, then the fact that the links to user pages are hardcoded to point to a specific folder is a bug?

dicko, tested as you suggested by specifying only /var/www rather than /var/www/freepbx. Everything seems to work fine now, even user pages. Thanks for your help.