Another way to skin a cat?

I have been wrestling with a method on showing a user on a BLF key so they are not disturbed. I have actually found little to use the DND function to accomplish this. I have an idea but do not have the skill set to do what I want. Here is my idea. Could a feature code be used to put the extension in “Busy” status and light a light on the phone itself? The light part is icing on the cake. I know enough that I know that I need to modify the dial plan. That is as far as I can go at the moment. Is this idea workable? Instead of the usual Do Not Disturb I want to name it Don’t Bother ME.

Suggestions, comments…

Thanks for all

The FreePBX DND does exactly this. What is the problem with using that?

IF it does what am I doing wrong. I use the EPM to program a BLF key on the Aastra 6731i phones for one extension. I go to that extension and enter *76 and the system says that DND is enabled. All the BLF lights for that extension are dark. If he makes a call them the lights go on. I have a DND key on each phone that dials *76 and it works as expected but without the lights lighting. I even contacted Aastra and they said it wasn’t possible. The same thing happens on the one Yealink t26 I have connected. When I look at the DND hint for the extensions that are in DND the status is idle. I have the User and Device mode set to Extensions. So if there is something I have missed I don’t know where to look.

Here are the hints
*[email protected] : Custom:DEVDND110 State:Idle Watchers 0
[email protected] : SIP/110&Custom:DND11 State:Idle Watchers 1
From everything I have read and what I see the status does not change from idle

The BLF has to be setup as *76110. We do this daily for people. So each phone would have to have the BLF setup as *76XXX with XXX being the extension number.

BTW if using the Commercial EPM then you can put in the value field *76%line1Ext%

%line1Ext% is one of the many variables you can use in EPM and tells the system to make the button be *76 and the extension number for that phone. You can find a full list of variables that can be used in EPM at http://wiki.freepbx.org/display/FCM/Variables+exposed+in+Base+File+Editor

Hi Tony
I have tried *76110 as the entry for the BLF. After I put 110 in DND the hint for it at *76110 does not change from idle so the button does not light. Is there a setting that I missed somewhere for this to work? Once I get this working the commercial EPM will be attractive. One question about it tho. Using that method you mentioned will I be able to also use the key to transfer a call or place a call to that extension, making it a dual purpose button?

Again Thanks

No that key is for toggling DND only. Not sure why your hints are not working.

OK then the *76110 key would be used on the extension to be monitored and a regular blf key with 110 on the other phones to keep track of the status of 110. I am going to try this on a fresh install and see what happens

Tony,
I’ve been fussing with this and I looked at the dialplan and to me it looks like it should be changing the status of the extension that is entering *76. Here is a part of the log files:

[2013-09-09 09:21:56] VERBOSE[1374] pbx.c: – Executing [*[email protected]:9] Playback(“SIP/110-0000000c”, “do-not-disturb&activated”) in new stack
[2013-09-09 09:21:56] VERBOSE[1374] file.c: – <SIP/110-0000000c> Playing ‘do-not-disturb.ulaw’ (language ‘en’)
[2013-09-09 09:21:58] VERBOSE[1374] file.c: – <SIP/110-0000000c> Playing ‘activated.ulaw’ (language ‘en’)
[2013-09-09 09:21:59] VERBOSE[1374] pbx.c: – Executing [*[email protected]:10] Macro(“SIP/110-0000000c”, “hangupcall,”) in new stack
[2013-09-09 09:21:59] VERBOSE[1374] pbx.c: – Executing [[email protected]:1] GotoIf(“SIP/110-0000000c”, “1?theend”) in new stack
[2013-09-09 09:21:59] VERBOSE[1374] pbx.c: – Goto (macro-hangupcall,s,3)
[2013-09-09 09:21:59] VERBOSE[1374] pbx.c: – Executing [[email protected]:3] ExecIf(“SIP/110-0000000c”, “0?Set(CDR(recordingfile)=)”) in new stack
[2013-09-09 09:21:59] VERBOSE[1374] pbx.c: – Executing [[email protected]:4] Hangup(“SIP/110-0000000c”, “”) in new stack
[2013-09-09 09:21:59] VERBOSE[1374] app_macro.c: == Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘SIP/110-0000000c’ in macro ‘hangupcall’
[2013-09-09 09:21:59] VERBOSE[1374] pbx.c: == Spawn extension (from-internal, *76, 10) exited non-zero on ‘SIP/110-0000000c’
[2013-09-09 09:21:59] VERBOSE[1374] pbx.c: – Executing [[email protected]:1] Hangup(“SIP/110-0000000c”, “”) in new stack
[2013-09-09 09:21:59] VERBOSE[1374] pbx.c: == Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/110-0000000c’
[2013-09-09 09:21:59] VERBOSE[1492] chan_sip.c: == Extension Changed 110[ext-local] new state Idle for Notify User 123

It looks to me as it changed the state to idle.

I tried something else. I setup a new system with 2.10. I assigned 1 new extension. I registered that extension to the system and was able to call into the voicemail. I programmed a button as *76123 (123 being the extension) I then dialed *76 and set the extension into DND–Got the DND Avtivated message. No light. I reprogrammed the lite to BLF 123 and when I dialed the DND toggle the light came on each time. So I know the light goes on when the phone is in use. So now what do I do??

I might have mis stated something in the last message. When I used the phone to dial *76 or to dial the voicemail the BLF (programmed to 123) lit while the phone was in use. When it wasn’t in use the light is out.

Anyone have any ideas why the state doesn’t change??