Another outgoing CID issue


i’ve search and try various tip, tricks a solution but i can’t find out how to be able to use Extension CID on outgoing call.

  • force a CID at the trunk level without any success
  • tryed various sendrpid and trustrpid setting without success

I’ve call my provider (Unlimitel) and they confirm that i can change my outgoing CID with my PBX

I have 2 trunk that are set to
CID Options: Allow Any CID

PEER Details


USER Details:


Outgoing Route are NOT set to overide Extension CID

Extension Outbound CID are set to the folowing format : “TEST” <1112223333>

Log goes like this :


Any suggesiton / idea ?

Hi corotte!

You might want to reread what you wrote…

On one line you say you want to use the extension CID and on the next you are suggesting that you forced one at the trunk level…

I will assume that you want to use the extension CID since it seems to be what you want to do…

I would suggest that you look the the following things:

  • Are you respecting the proper format for setting a CID at the extension level?
  • Is it possible that you set a CID at the outbound route level?
  • Is it possible that you set a CID in your provider configuration screens? I don’t know if Unlimitel does this but with you can force one on your account/subaccount configuration on their servers… It’s supposed to be used with ATA adapters, not with PBXes…

Please let us know how it turns out…

Have a nice day! / Bonne journée!


Thanks for quick reply

Sorry for beeing unclear. I just try to force the CID at the trunk level to test if CID will be passed to my provider then to the destination.

Your right, i want to use CID at the Extention level

  • I guess. is “TEST” <1112223333> the correct format ? I live in Canada. I’m not quite familliar with the CID format that need to be used. I found this one on this forum
  • yes and no. i put one and no success even if i use the “force” option. leave it blank with “allow any CID”; no luck …
  • i called them and my setting were correct on their control panel the whole time

does the log tell you something i missed ?
It is a log of a call i made to the support tech of my provider and they did not se the CID i’ve put at the extesion level.


Yes and no… The format is good but the number is not, the area code cannot start with a 1…

I assume however that you are using a real phone number that starts with something like 514, 438 or 450 but I could be wrong about it…

Are we talking about the trunk or outbound route(s)? You seem to use trunk terminology here…

It’s actually correct to use a caller ID hardcoded on their servers if they allow it but not if you are using a PBX… That’s actually more a config for an ATA adapter… They might or might not have checked for that…

I don’t know if your provider allows this though but I know of some that do (like…

Is the CID you are getting currently the “default” one and the only one your PBX seems to be able to send?

By the way, you mentioned having two trunks, why? A regular one and an Emergency one?

It could and so could screen captures I guess…

Good luck and have a nice day!


  • i replace “TEST” <1112223333> to a real number i own : still no luck
  • i’m talking baout trunk (sorry for confusion)
  • the CID have 3 option in their contorl panel : Dynamic, Static or Private. Dynamic is the one i use since i want to “push” my CID from the PBX.

talking about outgoing route, no CID here and override is off

i’m using two DID because i use one for my home and recover my old cellphone number since i don’t have one anymore. I also plan to port a new one in a near future since my father-in-law is pretty interested in saving on his phone bill.

The main reason why i want to use Extension CID is because i plan to do some test with him before porting his CID.

Makes sense…


OK, I read two trunks earlier and you usually only need one trunk per provider…

I hope that you did not cancel it before porting it to VoIP otherwise you lost your phone number…

Will he be using your PBX or directly theirs? You are in for a lot of fun if you open your SIP ports to the world…

(People are going to try to hack you…)

OK… I guess he will be using yours…

Just to make sure, you did not directly edit sip.conf, rtp.conf and extensions.conf like their wizard is suggesting right?

Good luck and have a nice day!


1 Like

don’t worry about DID porting. It is done. I port it before closing the cellphone account.

i’ve setup a VPN for that. Did not want to have my sip port open to the world …

i did not directly edit conf file like they suggest. I used it as a basis to configure trunk in freepbx

i’ll try to get a log for you.

EDIT : i’ve alreay post a part of the log file in the beginning of this thread. Can you look at it ?

In this scenario

can spoil your whole day


Man oh Man !!!
that made the trick … damn. i spend way too much time trying to figure it out myself before posting here.

THANKS A LOT !!! :grinning:

Yikes, never again will I not question the VoIP provider provided information…

Good catch!

Have a nice day!


fromuser= will always do that, that’s what it does :wink:

1 Like

Yep, I have read about it’s use and how the caller ID must be provided when your provider requires this for authentication but his provider actually asked him to set this as he did…

Something is obviously wrong in the information they provided especially considering they let you change the caller id…

I should have questioned their suggested configuration, I did not…

Have a nice day!


Start with

read it all, (twice!)

1 Like

Will do but my point was that I did not question it because it came from the VoIP provider…

Baaaaaaaaaaaaad idea… :unamused:

Have a nice day,


Never believe anything, until you have proven it yourself.