Anomaly in setting the time


(Claudio Pelosi) #1

I have set the time slot correctly
In fact, if I “clock” the linux shell I get it now right …
If I check with phpinfo it is also set them correctly …
“Europe / Rome”
And if I do an echo from php it gives me the correct time!
But if I go in “time condition” it gives me an hour less …
I don’t know where to go to see
Tips?


(Claudio Pelosi) #2

possible that it does not show “summer time” in “time condition”?
Because the operating system and the php give the right time …


#3

There are at least two php.ini 's one is used by your shell, another by your webserver.


(Claudio Pelosi) #4

I checked here is the result:

grep ‘date.timezone’ /etc/php.d/*.ini

grep ‘date.timezone’ /etc/php.ini

date.timezone = Europe/Rome


(Claudio Pelosi) #5

I checked my freePBX they are all obviously set to “Europe / Rome”
And they all give an hour less on the “time zone” interface.
Is it possible that “daylight savings time” is not displayed?
Everything works but the graphics are solar time and not daylight savings time


#6

From a shell paste

php <<< "<?php 
phpinfo();             
?> "

And look for ‘date’ and ‘time’

Paste the same (after the <<<) into a webpage and view it in your browser, Don’t forget to remo e it when done :wink:


(Claudio Pelosi) #7

date

date/time support enabled
“Olson” Timezone Database Version 0.system
Timezone Database internal
Default timezone Europe/Rome
Directive Local Value Master Value
date.default_latitude 31.7667 31.7667
date.default_longitude 35.2333 35.2333
date.sunrise_zenith 90.583333 90.583333
date.sunset_zenith 90.583333 90.583333
date.timezone Europe/Rome Europe/Rome

(Claudio Pelosi) #8

I have already checked the operating system and php and set the “PHP Timezone” to “Europe / Rome” in advanced
The great thing is that the system works fine but displays standard time not daylight saving time


#9

And from a shell

date -u -Iseconds
date -Iseconds

Should return the current UTC time.followed by correct Rome time?


(system) closed #10

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.