Annoying activation pop-up; Can't access domain; Firewall blocking trusted client


New user here. I have only tested FreePBX since today but already I have encountered being locked out by the firewall as soon as I logged in without any hint. After adding my IP and LAN to the trusted zone I thought that was it, but then I was locked out again after a while. I had to deactivate the firewall to get back in. I still have not figured this out because I am not in the blacklist and there was no fail2ban log or iptables rules indicating a firewall action.

Now I’m just trying to read the solution to the issue “activation pop-up not going away” ( )after aborting but I get the error “Request forbidden”. Even the website is frustrating. I know you are migrating to Github but could you not have waited until after the migration was done before locking people out of the solutions?

Is this how you get more people to buy support?

Certainly! For the firewall issue, you can try manually adding firewall rules using iptables .

iptables -A INPUT -s your_IP_address -j ACCEPT

Replace your_IP_address with your actual IP address.

As for accessing the solution to the FreePBX issue, if you’re encountering “Request forbidden” errors, it’s likely a permissions issue on the website. Unfortunately, there’s not much you can do about it directly. You may need to contact FreePBX support or wait for them to resolve the issue.
Best regard
Danish hafeez | QA Assistant

I would have thought adding an IP to the trusted zone would remove the need to whitelist it manually in iptables.

Until I can get rid of the permanent “Portal Account” pop-up window, the web GUI is unusable. It was triggered by /admin/config.php.

Can someone please at least post the solution here?

you have to finish the setup process for it to go away.

Do the setup process, go through and go as far as you can. Assuming you get locked out (or you’re still locked out", SSH into the PBX, and run the command “fwconsole firewall add trusted insertyouripaddress”

That will allow you to continue

My IP is already trusted and I can access the console and SSH presently. The crippling problem is with the web GUI. I cannot do anything with it.

Do you know the terminal command to remove the “Portal Account” pop-up window?

If you skip activation, you wont be able to use commercial products but if you simply want use of the GUI try running the following command

fwconsole ma disable sysadmin

after its disabled, you should be able to get into the PBX, and set it up and enable sysadmin again

I got this error:

Cannot disable: The following modules depend on this one: areminder,broadcast,callerid,calllimit,conferencespro,cos,endpoint,extensionroutes,faxpro,pagingpro,parkpro,pinsetspro,qxact_reports,recording_report,restapps,sangomaconnect,sangomartapi,vmnotify,voicemail_report,vqplus,webcallback,zulu

What does your GUI screen look like?

Thats the normal screen. You put your email address. I usually tab after, and after about 5 seconds the password screen will appear and you should be able to login

If you do not have a login, make one over at

I’m clicking Abort but it doesn’t work.

Is activation free? I have to read about it. I’m assuming I don’t need it.

yes, the account is free. sign up and activate. then you wont need to worry about abort

Sangoma wants me to provide a lot of personal information. I don’t want to buy anything. I will pass for now.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.