"an error has occurred" when going to voicemail

Voicemail is setup correctly on the extension, the call logs show the call going to vm100 (extension is 100).

Calls come in to 555-5555, they hit PBX, PBX sends call out to a ring-group, no one in ring-group answers, the call goes to Secretary Vm (x100)

The problem is coming when it hits VM, the system is saying “an error has occurred” and then disconnects.

I’ve tried rebuilding the extension to see if that fixes it, but to no avail.

Any ideas?

Assuming that ther is an appropriate

100 => . . . . in /etc/asterisk/voicemail.conf

I know of the three most common causes of that announcement.

  1. Tthe call was less than the seconds set in /etc/asterisk/voicemail.conf, default is:-

minmessage = 5 ; Minimum length of a voicemail message in seconds (easy fix but probably not this one)

  1. There are blank lines or bad newlines inappropriatly in /etc/asterisk/voicemail.conf after the

[default] line and before any next

[othercontext] line

line. (only older asterii and FreePBii I believe now) fix with

ypur favorite linux newline aware text editor

  1. The permisissions/ownership within the /var/spool/asterisk/voicemail/ directory structure are incorrect. fix with

amportal chown


Thanks dicko, I think I found the issue… in the /etc/asterisk/voicemail.conf in between a couple of the lines there were [] and thats it… so I deleted those… hopefully this fixed it.

Thanks for your help

It will, it always did at least, what version of FreePBX are you using, I thought that issue was long ago fixed . . .

hmm, haven’t needed to fix that bug since “way back when” maybe a bug report to freePBX?

exactly where that [] occurred would be very pertinent,

any extension before that [] would work, any extension after it would not, [] is an empty voicemail context that ends [default] as I stated.

does that give you a clue as to what you did and when?


I am Mike here…

I have faced the same issue but i could not found /etc/asterisk/voicemal.conf as mentioned by you all.

As my current Voicemail is still unable to enter and listen to it.

Pls advice.

Thank You.