Amportal a ma list -- returns almost nothing

My apologies if i missed solutions on previous posts (i did spend some time searching).
Any guidance is GREATLY appreciated.

Asterisk 11.17.1
SHMZ release 6.5 (Final)

initially I performed a module update and the GUI broke, normal reported blank page etc.

In an attempt to “Fix It” I have probably made things worse. Much worse

System has not “been in the wild” only port 5060 and 10000-20000 have been forwarded and i don’t suspect it has been compromised by anyone but me =P

The system appears to be servicing phone calls and operating normally, but without a GUI I personally cannot manage the system.

I am comfortable on the command line, but am very weak with asterisk and FreePBX and as such, I have not been able to figure out how to fix it.

amportal restart was hanging on xmpp

Based on googled articles, I have deleted xmpp and was able to amportal restart.
I later copied it back from a working system, but amportal restart no longer references it in the restart process.

At this point, amportal seems to be able to chown, stop, start etc, but the module admin functionality is broken.
attempting to amportal a ma ANY_VALID_COMMAND is returned almost instantly without the expected output

[[email protected] ~]# amportal a ma list

Fetching FreePBX settings with gen_amp_conf.php…

[[email protected] ~]#

[[email protected] /]# ls /var/www/html/admin/modules

_cache               core                  infoservices      recordings
_ep_phone_modules    cos                   irc               restapi
accountcodepreserve  customappsreg         ivr               restart
announcement         dahdiconfig           javassh           ringgroups
areminder            dashboard             languages         setcid
arimanager           daynight              logfiles          sipsettings
asterisk-cli         dictate               manager           sipstation
asteriskinfo         digium_phones         miscapps          sms
backup               digiumaddoninstaller  miscdests         sng_mcu
blacklist            directory             motif             speeddial
broadcast            disa                  music             superfecta
bulkdids             donotdisturb          outroutemsg       sysadmin
bulkextensions       dundicheck            paging            timeconditions
callback             endpoint              pagingpro         tts
callerid             extensionroutes       parking           ttsengines
callforward          extensionsettings     parkpro           ucp
calllimit            fax                   pbdirectory       ucpnode
callrecording        faxpro                phonebook         vmblast
callwaiting          featurecodeadmin      phpinfo           vmnotify
campon               findmefollow          pinsets           voicemail
cdr                  framework             pinsetspro        voicemail_report
certman              freepbx_ha            presencestate     vqplus
cidlookup            fw_ari                printextensions   weakpasswords
conferences          fw_langpacks          queueprio         webcallback
conferencespro       hotelwakeup           queues            webrtc
contactmanager       iaxsettings           recording_report  xmpp

amportal a dbug & clicking http://XXX.XXX.XXX.XXX/admin/config.php returns the following two lines.

[2015-May-21 20:06:18] [PHP-WARNING] (/var/www/html/admin/modules/conferencespro/ - No license for this product (PBXact) - make sure zend_loader.license_path is properly configured in your ini file!
[2015-May-21 20:06:18] [PHP-WARNING] (/var/www/html/admin/modules/conferencespro/ - License check failed!

can I yum erase/install specific items to restore amportal / GUI functionality?
Is there logging that I am missing?

Thanks again.

Just remove xmpp again. You copied an invalid version over. Do that then download from online

cd /var/www/html/admin/modules/
rm -rf xmpp/
service httpd restart
amportal restart

No change:
GUI is still blank

amportal a ma list still doesn’t return anything

[[email protected] modules]# amportal a ma list

Fetching FreePBX settings with gen_amp_conf.php..

[[email protected] modules]#

how do i download reinstall it if amportal a ma any command doesn’t do anything as expected.

I really appreciate your help and am tying to do what i can to resolve this, but keep getting dead end after dead end.
How am I supposed to download the xmpp package?

I found in a thread and it looks like a need 2.11 via module xml file.

cat core/module.xml | grep 'release'
                *12.0.1alpha2* Bump Version Number and make release 12 branch

yum list freepbx
Installed Packages
freepbx.noarch 12.0.45-1.shmz65.1.19
This Location is no longer accurate. We Will have something soon.

Do you need the “xmpp package” ?

if you don’t

amportal a ma delete xmpp

(you can do that with all the stuff you haven’t or won’t pay for or just don’t need)

ps sometimes you have to run those amportal commands iteratively until all underlying restrictions are fixed. :slight_smile:

I honestly appreciate the help, but I don’t think you are getting how broke amportal is on this system that I am trying to recover.

amportal a ma ANY COMMAND simply doesn’t do anything that I can tell.

amportal a ma list
amportal a ma installlocal
amportal a ma delete module
all do the same thing.

Fetching FreePBX settings with gen_amp_conf.php..

and then returns to the command prompt within 1 second from execution

I don’t need nor have I paid for any commercial modules. I am tying to recover the amportal patching process and subsequently the web gui.

Hours and hours looking at this and in IRC the fix to get amportal a ma command and the webgui back was to completely replace the html directory and all the symlinks from a working install.

The working install was the same version of the schmooze distro

rsync -rvza -e 'ssh -p 2222' --progress --links /var/www/html  [email protected]:/var/www
        -- where the ssh  server was temporarily opened on port 2222 on the phone server.
amportal chown
amportal a ma updateall
amportal chown
service httpd restart

After everything just worked.