Alphanumeric Passwords?

Moving from 2.5 to 2.10. Everything worked under 2.5. Nothing works under 2.10. I haven’t tried very hard to trouble shoot things until I find an answer to the following.

2.10 forces use of alphanumeric passwords (secrets). My Aastra 6730i phones want to see numeric only (per the lastest manual) -

Things were simple when everything was numeric. Now the question becomes, what types of alphas are allowed under ver. 2.10?

a) Lower case only?
b) Upper and lower case?
c) special characters allowed?

The 2nd question, is the above manual reference correct, and if so how are things matched up between ver. 2.10 and the 6730i’s.

I’m not afraid to research things but nothing has come to light so far. A link, reference, suggestion, anything but opinion is welcome. I’ve already been told the 6730i’s will and will not accept alphanumeric passwords with no details specified.

Thanks for any information.

You miss the point, the admin and user passwords are for access to the Aastra http(s) internal server and phone based setup menu, reasonably it needs to be numeric (and less than a long integer) because the keypad only has 0-9* and #, DO NOT under any circumstances leave the adminpassword at the default of 22222 or you will regret it.

The sip “secret” can and should be a mixture of UC, LC and numeric it should also be at least 10 char’s long for reasonable security, I suggest you keep away from reserved char’s like %$#@() as the common php interfaces can have problems with them.

(Largely not an opinion, just pragmaticism)

As to an admin manual, yours is third party, google for it (aastra administrator manual). For various reasons they no longer make it easy to find . . .

I’m sorry you think I don’t know the difference between User, Admin and SIP registry passwords. Yes, the Admin manual I was using was from core Aastra only it was ver. 2.6xx. Now for some info that may help others.

Several years ago the only presence I could find for Aastra was in Canada. They now have a branch in Frisco, Texas. An easy to find link to get you started for 6730i info is here -

It does now appear that the phones (with the latest firmware) do support alphanumeric passwords. If they support all three types listed above is still a question I am researching.

The latest Admin manual is pictured here (above link is dead) -

I could not find in the manual a statement as what firmware versions were supported but my assumption is the version number of the manual needs to match their firmware version as shown. A major kicker in my view is, when you unzip their firmware download you get a file listing of which is the same file name they have used for a number of years. I would have thought the ZIP carrier would have been a little more descriptive.

Anyway, my advise is to make sure the firmware version listed in the phone display is the same as the version number of the Admin manual you are using as shown.

Any other suggestions much appreciated.

Don’t be sorry, Aastra have always needed a numerical admin and root password (if you need to use the phone interface) and they have always accepted alphanumric sip authorities, at last for me over the last four years.

The name of the firmware is because that is what the phone will look for from the provisioning server, it is hardcoded into the phone’s firmware.