Allow SIP port and Outbound Proxy Port to accept 0 for the use of SRV

If you enter 0 the Outbound Proxy port in a template, saving the template results in the port being updated to 5060. This is wrong, 0 is an accepted port by phones and when using SRV.

This is also true of the SIP port, if not using an OB proxy one should be able to set the destination SIP port to 0 so phones can initiate the SRV protocol when desired.

When a port is set SRV, even went set as the preferred protocol, will be ignored and fall back to UDP to use the port that is assigned.

The current work around is to use Base File Edit in the EPM to manual edit each template that is going to be used. This shouldn’t be the way to do this, it should be a standard option in a template as it is a standard option in a phone.