All outgoing calls are anonymous

All outgoing calls are anonymous. I want to disable that option but I don’t know where. Extensions have CallerID’s but it doesn’t seem to work.

In most locales and systems, an “anonymous” CID is caused by a mis-configured Caller ID at the head end.

Before we go there, remember that there are at least four places where CID gets set in a SIP setting:

  1. The extension itself (in some soft phone apps) can set a Caller ID.
  2. The extension definition can set the Caller ID (if one isn’t set) or override (if one is).
  3. The outbound route can define or redefine the Caller ID.
  4. The trunk can define or redefine the Caller ID.
  5. The ITSP can define, redefine, or ignore and replace the Caller ID. Some ITSPs also block calls with “foreign” caller IDs and others will blank caller IDs that aren’t associated with the account the call is coming from.

In my experience, a Caller ID that isn’t in the format:

Name in quotes” <9999999999>

will give you an “anonymous” Caller ID. If you stick with this format, you should be in good shape. The company of the server receiving the call can also mark your call as “anonymous” for almost any reason they see fit.

1 Like

Thanks for reply! It was working great at some point, but I didn’t notice when it has changed…
Im sure i didn’t change anything in extensions and outbound routes… Only settings were sip trunk and chan sip.

I don’t know what to think now, in CDR I can see there is CID, but in fact it is anonymous.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.