All circuits busy message when dialing out using FXO port in UK - HELP!

Hi all,

I am quite new to this trying to setup a small office telephone system.

I am getting the “All circuits are busy now, please try your call again later” message when I try to place any outbound call.


I am in the UK using a UK BT line, I am not sure if this makes a difference…

The connection to the BT Line is through the FXO port on a Digium TDM410P card with 1FXO and 1FXS installed. The FXS port is working fine.


I am using:
FreePBX 2.8.0beta2.4
I have also tried it using Trixbox with no sucess!

I have a trunk setup with the following:

Trunk Name: ZAP Channel g0
Maximum Channels: 1
Dialed Number Manipulation Rules:

I have an outbound route setup:

Route Name: 9_outside
Dial Patterns that will use this route:
Trunk sequence:
0: ZAP channel g0

Please let me know what could be wrong, I am sure it must be something simple!

What do you have in the following files ?


Autogenerated by /usr/sbin/dahdi_genconf on Tue Jun 22 22:30:23 2010

If you edit this file and execute /usr/sbin/dahdi_genconf again,

your manual changes will be LOST.

Dahdi Configuration File

This file is parsed by the Dahdi Configurator, dahdi_cfg

Span 1: WCTDM/4 “Wildcard TDM400P REV I Board 5” (MASTER)


channel 3, WCTDM/4/2, no module.

channel 4, WCTDM/4/3, no module.

Global data

loadzone = uk
defaultzone = uk


; Copied from DAHDI Module of FreePBX


#include dahdi-channels.conf

#include chan_dahdi_general.conf


; include dahdi groups defined by DAHDI module of FreePBX
#include chan_dahdi_groups.conf

; include dahdi extensions defined in FreePBX
#include chan_dahdi_additional.conf

The includes are:


; Autogenerated by /usr/sbin/dahdi_genconf on Tue Jun 22 22:30:23 2010
; If you edit this file and execute /usr/sbin/dahdi_genconf again,
; your manual changes will be LOST.
; Dahdi Channels Configurations (chan_dahdi.conf)
; This is not intended to be a complete chan_dahdi.conf. Rather, it is intended
; to be #include-d by /etc/chan_dahdi.conf that will include the global settings

; Span 1: WCTDM/4 “Wildcard TDM400P REV I Board 5” (MASTER)
;;; line="1 WCTDM/4/0 FXSKS (SWEC: MG2)"
channel => 1

;;; line="2 WCTDM/4/1 FXOKS (In use) (SWEC: MG2)"
callerid=“Channel 2” <4002>
channel => 2




; Do NOT edit this file as it is auto-generated by FreePBX. All modifications to ;
; this file must be done via the web gui. There are alternative files to make ;
; custom modifications, details at: ;




; Do NOT edit this file as it is auto-generated by FreePBX. All modifications to ;
; this file must be done via the web gui. There are alternative files to make ;
; custom modifications, details at: ;

[email protected]
callerid=device <111>

I’m quite new to FreePBX, so I may be going about this all wrong. I was having the same problem, getting the “all circuits are busy” announcement when trying to place an outbound call. I found that, if the group was set to 0 for the FXO trunks in the DAHDi configuration page, FreePBX did not add the group=0 line to /etc/asterisk/chan_dahdi_groups.conf. From the looks of your chan_dahdi_groups.conf, it looks this wasn’t some anomaly on my install.

I manually edited my file (bad, I know, but it was just for troubleshooting), added the group=0 line, and things started working. I’ve since changed my FXO trunk to be g1, and FreePBX updates the file properly. I need to do some more testing, but I thing we may have found a bug.

I’m on 2.8, so the menus might be slightly different than what you see on 2.7. Go into the Admin page, then to DAHDi. You should see your FXS and FXO ports listed, and there should be an edit link to the right. Click the edit link on your FXO port, then put “1” in the Group field. (I also had to put “from-zaptel” in the context field to get inbound calling working.) Save the changes, click the “Install chan_dahdi.conf” link just below the orange “Apply Configuration Changes” button, then click “Apply Configuration Changes” and place an outbound test call. If it doesn’t work, take a look at your chan_dahdi_groups.conf file and see if the FXO (signalling=fxs_ks) port has the group=1 line present.

Dude you say your “I’m quite new to FreePBX” well you sound like an expert to me! Thanks SO much!

hi, i parham and i am new in this field.
i have the same problem with TDM410 (4*FXO), i did what you said exactly , but it is not working . the card doesn’t pickup when i call it’s number. when i try to call outside (like 9118 or …) it say “all-circuits-busy-now” and “pls-try-call-later”.
i upgrade the system to 2.8.
i checked chan_dahdi_group.conf and …

i am really stuck.

I’ve just been driven mad by this for a few days.

I found that the fix that Tadpole describes above finally fixed it; Thanks Tadpole!

Worked like a charm. Thanks!

Thanks SO much. Iv been beating my head on the wall for like an hour and changing it to group 1 fixed the issue for me.

Did anyone report this as a bug?

Asterisk (Ver. 1.8.11)
FreePBX is version 2.10

Finally i found the solution to this bug. I had the same problem, and I have been beating with it 2 weeks ago.

Thaks for the solution… partners. :wink:

Same: Asterisk 1.8.11, FreePBX 2.10.

Quiet long thread, instead of concentration on finding solution many people just complain.

Anyways, I have AsteriskNow 2.0.2 with FreePBX (No Idea about version) + Digium wctdm24xxp FXO 4 ports card.

Make sure that your card is recognized by Linux, if you type dmesg you will see someting like
wctdm24xxp 0000:0c:08.0: Booting VPMADT032
wctdm24xxp 0000:0c:08.0: VPM present and operational (Firmware version 125)
wctdm24xxp 0000:0c:08.0: Port 1: Installed – AUTO FXO (FCC mode)
wctdm24xxp 0000:0c:08.0: Port 2: Installed – AUTO FXO (FCC mode)
wctdm24xxp 0000:0c:08.0: Port 3: Installed – AUTO FXO (FCC mode)
wctdm24xxp 0000:0c:08.0: Port 4: Installed – AUTO FXO (FCC mode)
wctdm24xxp 0000:0c:08.0: Found a Wildcard TDM: Wildcard AEX410 (0 BRI spans, 4 analog channels)

Then in FreePBX you go to “Other” menu right after “Settings”. In the “Analog Hardware” section there is a link to edit settings, go there and enter group “1” and context “from-zaptel”. Click save, then apply changes, then click “Install chan_dahdi.conf” then again apply changes.

After this gymnastics in Linux command line do “amportal restart” or simply reboot the PC. You need to do this to get your channels added to DADHI.

Now after you did all this go to “Connectivity” menu, then do “Add DADHI Trunk”. In the new trunk menu specify the number of channels that your card supports, and now very important step: in “Outgoing Settings”->“DAHDi Identifier” you need to put the same group number 1.

Then create outbound rules that will use this new DADHI trunk.

Nope this helps everybody.

Thanks for the write up HappyHunter but it only applies to Asterisk now.

The DAHDI module is part of their distribution and to my knowledge does not support the latest version of FreePBX.

Digium kink of went their own way on this one. They never submitted the module for QA or inclusion in the FreePBX repo.