"all circuits busy" message instead of busy signal when calling busy phone


Users are getting the message “all circuits are busy” instead of a busy tone when placing outside calls to a line that is busy. If we call the number from a cell phone for example, we just get the usual busy tone.

Do we have something set up wrong?

Any help would be greatly appreciated


I get the same result on FreePBX Distro 12 with Asterisk 11. I’d like to find a solution because they come running to me thinking something is wrong with the system when they just dialed the number wrong.

There is a “route congestion messages” module available. BUT, many sip providers return inappropriate SIP responses to bad/unavailable routes

Reviving an old thread.
Believe it or not, we’ve only just noticed that this is happening.
User was getting intermittent “circuits busy” message, which they associate with a fault, and reasonably so, it is the message that will be played if the trunk connections go away. Turned out that the number they were calling was busy, we got this information from the SIP provider.

I want a busy signal where appropriate, and an all circuits message when needed, from what I can see in the Route Congestion Messages, I have one selector for “Standard Routes” and that’s it.

I’ve switched it to tones now, to prevent the users confusion. This leads to a second point: when calling a busy phone, the user hears a brief ringing tone and then the engaged tone. This is because Asterisk is playing the call progression tone while establishing the call through the PSTN, but it is rather confusing again. To complicate things, I have these tones turned OFF in advanced settings. Asterisk Dial Options is blank and so is Asterisk Outbound Trunk Dial Options.

Any suggestions?

What is the SIP response code when you call a busy number. it should be 486 which would result in a busy tone being played.

It was indeed 486 (something like ‘everyone busy here’ ?) and resulted in the Alison message “All circuits are busy now” instead of the busy tone.

Hello all.
I realise I’m necroposting, but yesterday I ran into the same problem on FreePBX 13 and spent several hours fixing it. SIP 486 clearly coming from the trunk, “all circuits are busy” on the calling extension instead of busy tone.
The problem was observed on only one of the outbound routes, other routes worked as they should.

In the end it turned out that the single trunk used by affected outbound route had “Continue if Busy” parameter accidentally set to “yes”. I set it back to “no” and that solved the problem.

1 Like