All Circuits are busy

I just got my number ported today with Voip.ms. It was working fine all day. Now I am getting “all circuits are busy” only on outgoing calls. The logs show “Received response: “Forbidden” from ‘sip:[email protected];tag=as0774d07e’”

Is there a question here?.

We can all guess that you think it is broken, but without anything further from you we can just commiserate with you. . . .

As ever , you will need to post a log of a failed call and the methods by which you have provisioned your system.

the error I posted above shows in the logs every time I attempt to make an outbound call. What log do you need?

The whole log perhaps? from the beginning to the end of the call perhaps?.

okay this is very strange. I found the issue from restoring my system from backup. We deleted an old sip provider which caused the issue. It appears it has dial patterns that we did not setup on the new provider. I setup the exact dial patterns and still have the issue when I dial out. I’ll do another test and attach the log.

That will be good, there are no mind readers here to know what you did before it stopped working.

here is the log:

[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] app_dial.c: Called SIP/Voip.MS outgoing/14195664392
[2016-05-23 00:05:49] WARNING[2224][C-00000087] chan_sip.c: Received response: “Forbidden” from ‘sip:[email protected];tag=as4612ba80’
[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] app_dial.c: Everyone is busy/congested at this time (1:0/0/1)
[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] pbx.c: Executing [[email protected]:24] NoOp(“SIP/103-0000009c”, “Dial failed for some reason with DIALSTATUS = CHANUNAVAIL and HANGUPCAUSE = 21”) in new stack
[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] pbx.c: Executing [[email protected]:25] GotoIf(“SIP/103-0000009c”, “0?continue,1:s-CHANUNAVAIL,1”) in new stack
[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] pbx_builtins.c: Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)
[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] pbx.c: Executing [[email protected]:1] Set(“SIP/103-0000009c”, “RC=21”) in new stack
[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] pbx.c: Executing [[email protected]:2] Goto(“SIP/103-0000009c”, “21,1”) in new stack
[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] pbx_builtins.c: Goto (macro-dialout-trunk,21,1)
[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] pbx.c: Executing [[email protected]:1] Goto(“SIP/103-0000009c”, “continue,1”) in new stack
[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] pbx_builtins.c: Goto (macro-dialout-trunk,continue,1)
[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] pbx.c: Executing [[email protected]:1] NoOp(“SIP/103-0000009c”, “TRUNK Dial failed due to CHANUNAVAIL HANGUPCAUSE: 21 - failing through to other trunks”) in new stack
[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] pbx.c: Executing [[email protected]:2] ExecIf(“SIP/103-0000009c”, “1?Set(CALLERID(number)=103)”) in new stack
[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] pbx.c: Executing [[email protected]:7] Macro(“SIP/103-0000009c”, “outisbusy,”) in new stack
[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] pbx.c: Executing [[email protected]:1] Progress(“SIP/103-0000009c”, “”) in new stack
[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] pbx.c: Executing [[email protected]:2] GotoIf(“SIP/103-0000009c”, “0?emergency,1”) in new stack
[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] pbx.c: Executing [[email protected]:3] GotoIf(“SIP/103-0000009c”, “0?intracompany,1”) in new stack
[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] pbx.c: Executing [[email protected]:4] Playback(“SIP/103-0000009c”, “all-circuits-busy-now&pls-try-call-later, noanswer”) in new stack
[2016-05-23 00:05:49] VERBOSE[15578][C-00000087] file.c: <SIP/103-0000009c> Playing ‘all-circuits-busy-now.ulaw’ (language ‘en’)
[2016-05-23 00:05:50] VERBOSE[15578][C-00000087] file.c: <SIP/103-0000009c> Playing ‘pls-try-call-later.ulaw’ (language ‘en’)
[2016-05-23 00:05:53] VERBOSE[15578][C-00000087] pbx.c: Executing [[email protected]:5] Congestion(“SIP/103-0000009c”, “20”) in new stack
[2016-05-23 00:05:53] WARNING[15578][C-00000087] channel.c: Prodding channel ‘SIP/103-0000009c’ failed
[2016-05-23 00:05:53] VERBOSE[15578][C-00000087] app_macro.c: Spawn extension (macro-outisbusy, s, 5) exited non-zero on ‘SIP/103-0000009c’ in macro ‘outisbusy’
[2016-05-23 00:05:53] VERBOSE[15578][C-00000087] pbx.c: Spawn extension (from-internal, 4195664392, 7) exited non-zero on ‘SIP/103-0000009c’
[2016-05-23 00:05:53] VERBOSE[15578][C-00000087] pbx.c: Executing [[email protected]:1] Macro(“SIP/103-0000009c”, “hangupcall”) in new stack
[2016-05-23 00:05:53] VERBOSE[15578][C-00000087] pbx.c: Executing [[email protected]:1] GotoIf(“SIP/103-0000009c”, “1?theend”) in new stack
[2016-05-23 00:05:53] VERBOSE[15578][C-00000087] pbx_builtins.c: Goto (macro-hangupcall,s,3)
[2016-05-23 00:05:53] VERBOSE[15578][C-00000087] pbx.c: Executing [[email protected]:3] ExecIf(“SIP/103-0000009c”, “0?Set(CDR(recordingfile)=)”) in new stack
[2016-05-23 00:05:53] VERBOSE[15578][C-00000087] pbx.c: Executing [[email protected]:4] Hangup(“SIP/103-0000009c”, “”) in new stack
[2016-05-23 00:05:53] VERBOSE[15578][C-00000087] app_macro.c: Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘SIP/103-0000009c’ in macro ‘hangupcall’
[2016-05-23 00:05:53] VERBOSE[15578][C-00000087] pbx.c: Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/103-0000009c’

Generally cause 21 can be interpreted as

Cause No. 21 - call rejected.
This cause indicates that the equipment sending this cause does not wish to accept this call. although it could have accepted the call because the equipment sending this cause is neither busy nor incompatible. This cause may also be generated by the network, indicating that the call was cleared due to a supplementary service constraint. The diagnostic field may contain additional information about the supplementary service and reason for rejection.

What it means:
This is usually a telco issue. The call never reaches the final destination, which can be caused by a bad switch translation, or a misconfiguration on the equipment being called.

You will have to check with your provider both billing (you paid) then engineering (you dialed correctly) and your professed CID is acceptable.

(You did not paste the whole call, just the bits you though were needed, please just do as asked next time)

how can it be a telco issue when it works after a restore?

Whole log is too big. I don’t see an area to even attach it here.

FreePBX

Sorry I’ve done my best, the call log started at the first instance of VERBOSE[15578] and ended at the last.

Because the rejection is from your carrier, then there is nothing else I can help you with here it was not FreePBX, Obviously you are restoring something different, go find that otherwise good luck with it.

thanks for your help

call voip.ms or chat with them online. send them your sip trunk config - they are pretty good about helping

Unless things have changed, VOIP.MS only does chat. Quite often when I chatted with them the answer was, try another server. It worked, until it didn’t.

You may want to check and veryfy that the dial string that you are sending to VOIP.MS is correct. No 1 or 0 in front of the 10 digit number. Your VOIP.MS account is configured to connect to the server your trunk is? They must match.

If you take a look at their Wiki, and copy in information, changing the username and password, it should work.

Outgoing calls have nothing to do with your phone number, or the porting thereof.

Generally, outbound calls are rejected because:

  1. Username and password don’t match.
  2. Codecs don’t match.

Create a brand-new sub-account with VOIP.ms with a new name and password. Make sure that all allowed codecs are enabled,

Create a brand new Trunk to connect to the new sub-account (use a different server) to make sure that everything is set correctly.

If that works, then something’s wrong either with your sub-account configuration (likely the password or codecs) or with your Trunk configuration.

Thanks for the tips guys. I found an old sip provider and removed that. All up and running now