"All circuits are busy now"

Hello,

I know that this is probably a repeated topic. However, I have setup a few FreePBX installs before and this is the first time I have gotten this issue although I am using nearly the same config for outbound calls as I am this one.

The log for the asterisk call is below:

It is in pastebin since the log is too long for here.

Thank you for any assistance I can get.

Everyone is busy/congested at this time (1:0/0/1)

This is unavailable, rather than busy. The numbers are: total channels called, number busy, number congested, and number unavailable.

As there is nothing else logged, I assume you have a qualify failure, and if you look at the endpoint status, you will find it is “unreachable”. Qualify involve sending OPTIONS requests, and seeing whether they produce any response at all (even method not supported is good), within a reasonable round trip time.

I get the below when looking at Asterisk Info.

The Congested/Busy message can be a red herring. It’s possible a config issue that there is something the provider doesn’t like.

I would suggest taking a PCAP and see what the actual response is from the provider.

At the Asterisk command prompt, type
pjsip set logger on
make another failing test call and paste the Asterisk log.

Hiya,

Thanks.

I’ve done that and here is the log:

They have refused your call with 603 Decline, without asking you for a password. If you should be supplying a password, it probably means they haven’t recognized your account. If you are using IP authentication, it probably means your public address isn’t the one registered with them.

They’d normally take the account from the From header,

The only IP address which is associated with the FreePBX node is the one which should be authorised with them. I’ll contact them.

You might also get it the caller ID you are presenting (03302293720) isn’t one that they believe you control, or isn’t being recognized, because it isn’t in the expected format.

On the Dial 9 portal, go to Trunking → Outbound trunks and confirm that your PBX IP address is properly set there.

Do incoming calls work properly?

In your example, you are calling your own number, which Dial 9 may be treating specially. Do you get the same error when calling e.g. a Freephone number?

Hiya,

Incoming calls work fine. I cannot call our own number either. Though, I can perform internal calls to other extensions.

The IP address in there is the correct IP address.

In what country are you calling from?

It’s a UK DDI with a UK provider.

I suspect it’s the the Outbound CID not in the correct format they are expecting. It could also be the number you are dialling not being presented correctly either.

He’s on Sky in UK. But why should that matter? PBX is on Volt in UK using UK trunking provider calling from and to UK numbers. The country the OP is in should not be visible to the provider.

I thought that, too, but the From header is apparently a User ID and not a number, according to

AFAICT the PBX is set up perfectly.

Just some guesses: Try removing and re-adding your IP address on the portal in Trunking → Outbound trunks; possibly the back-end didn’t update. Check your balance; some providers will block outbound calls if balance is less than some threshold, while still permitting incoming. Try removing codecs other than ulaw and alaw; the others could somehow be confusing the provider. Try calling another number (such as your mobile) and see whether you get the same error.

If you still have trouble, try adding your Sky IP in Trunking → Outbound trunks and test whether you can call from a softphone.

1 Like

Another guess: Try setting From Domain for the trunk to sip.dial9.co.uk – the setup instructions might be incomplete.

Hiya,

Thank you all for your replies.

I did that originally and then left it overnight to see if it just took time. Didn’t seem to work sadly.

Balance is sufficient.

Yes, I get the same error no matter what I call.

Hi all again,

I got my client to contact the customer service for dial9.

The PBX and my configuration were all setup correctly.

I don’t know what Dial9 responded with, but it looks like it was an issue on their end.

Its all resolved now. Thank you everyone for all of your replies! Its really appreciated that you all helped me with this.

2 Likes