All circuits are busy now

I have been trying to figure out what happened to my freepbx system and its connection to flowroute that is now causing me to get “all circuits are busy now” from my PBX when i try to dial out. I run the ‘pjsip show registrations command’ in asterisk cli and shows my trunk is registered.

I see this error in the asterisk log
[2019-05-12 18:45:29] ERROR[58265] res_pjsip.c: Endpoint ‘FlowrouteTRUNK’: Could not create dialog to invalid URI ‘FlowrouteTRUNK’. Is endpoint registered and reachable?
[2019-05-12 18:45:29] ERROR[58265] chan_pjsip.c: Failed to create outgoing session to endpoint ‘FlowrouteTRUNK’

Any ideas for things to check?

Can you post the full call log?

This is usually caused by the trunk appearing ‘unavailable’ (no response to OPTIONS).

If the Contact does not show avail, you could test by disabling Qualify, which should cause the call to be attempted (though it will likely fail).

At the Asterisk command prompt, type
pjsip set logger on
and you should then see OPTIONS requests being sent and any replies received.

here is the log file for a sample call that failed

here is a second example

Outbound calls on Flowroute can use either IP Authentication or Registration. It appears that you are using Registration but your REGISTER requests are failing:
[2019-05-14 19:24:31] WARNING[58265] res_pjsip_outbound_registration.c: Fatal response '401' received from '' on registration attempt to 'sip:[email protected]', stopping outbound registration

Go to and confirm that registration is enabled and that your Username and Password match the Username and Secret in your trunk settings.

In FreePBX ad Reports -> Asterisk Info -> Registries, you can see whether your trunk is successfully registered. If you still have trouble with registration, post screenshots of your trunk settings (masking username and secret).

If your PBX has a static IP, it is recommended to disable registration for outbound and use IP Authentication instead. It’s a little more secure (no password to get stolen), faster (don’t have to authenticate on each call) and more robust (no possibility of 'lost registration). See .

i double checked and copied the username/tech prefix, and password, along with the sip address back in. Still get the same issue. I am linking my trunk config. Note i changed from the VA server back to the NJ server.

Any ideas what I am doing wrong?

What error are you getting in the /var/log/asterisk/full log file?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.