All circuits are busy now

Hi There everyone.

This forum has been so much help to me all through my FreePBX Usage, It is an awesome Product.

I have one question, when i dial a number that is busy, for example i dial my cell phone while it is in the middle of another call, it tells me that “all circuits are busy now” I was wondering if there was a way to change it so when the other end is busy it would let me know that specifically?

Kind Regards

All circuits are busy is a local message; this sounds more like you are hitting your limit of concurrent calls with your SIP provider…

Thanks, I though that aswell at first but even when i make sure no one is making calls i still get it.
I know for a fact it happens when the other end is busy.

I’ve just read my example and realized it doesn’t make much sense…
Basically if a person is on a call and you call them you would normally get the engaged tone.
I’m looking for a way to emulate that on my FreepBX box for outbound external calls.

Hope that makes more sense :slight_smile:

I don’t think I’ve had that happen…what version of FreePBX/Asterisk are you using, and who is your SIP provider?

When I make a call and the number is busy, I get the busy tone.

Can you connect to the console via asterisk -rvvvvvvvvvv and paste the output after making a test call? Use pastebin if your account is too new.


Thanks for that, I am not in the office right now but as soon as i get in i will be able to do the test call and paste the Logs.

I can tell you now my Provider is AVOXI and i am running FreepBX/Asterisk version with the following Firmware:10.13.66-1 and Service Pack:

If there is anything else you can think of before i have had a chance to make the test call please let me know.

Thanks again :slight_smile:

The Asterisk version differs from the FreePBX version, you’ll want to provide that as well.

Look up Asterisk call files…if you can SSH in, you can place a test call :slight_smile:

“all circuits are busy now” unfortunately it generate more confuse than benefits, these could become from miss configuration on outbound routes or ISDN network call disconnect causes.
It can change setting of play message “all circuits are busy now” to reorder tone, on your configuration.

Unfortunately it is VSP dependent, many do not/will not signal properly busy signals ( ity should be a SIP 486)


might let you ameliorate some of your problems.

Hi Everyone,
@Overkill Thanks for all the help it was greatly appreciated.
@mcgrathr Thanks for the suggestion, i went through the route config with my VSP and it was all correct from their end but they then told me that they do not signal proper busy signals as dicko mentioned.
also dicko thanks for the suggestion, i will definately look into this to see if it can help with some of my problems.
(apparently i can only mention two users, sorry dicko :slight_smile: hope you forgive me)

Again thanks to everyone who assisted with this.