Agent on a call still getting incoming calls when set to skip

I have the queue set to Ring All and set to Yes for Skip busy agent

Agent A is on a call on line 1 and their Line 2 will ring for the next caller in the queue even though they are from the queue set to skip. Will this work with Ring All?

Do they have call waiting enabled? CW makes it so at least two calls exist before busy.

If you are talking about another call in the same queue and it goes to the same extension, then no, it shouldn’t be that way.
To what do you have Skip Busy set to?

I don’t think that ring strategy or Call Waiting makes a difference with this. If set to Yes, it’s supposed to try the next agent.

Again, if say you have Queue 200 with extension 101 & 102:
Call 1 comes in to 200, 101 answers.
Call 2 comes in to 200 while 101 is on the phone, it rings 101. Then something is wrong here and you’ll need to look at the logs.

Logs: Providing Great Debug - Support Services - Documentation

They do, however per the docs it says it ignores that. I am thinking its the RIng All strategy it doesnt link.

from docs:

When set to ‘Yes’ agents who are on an occupied phone will be skipped as if the line were returning busy. This means that Call Waiting or multi-line phones will not be presented with the call and in the various hunt style ring strategies, the next agent will be attempted.

Which version of Asterisk, FreePBX & Queues are you on?

Again, IIRC this is supposed to work with all Ring Strategies.

Logs should tell you whats up, if you don’t know how to read them, post it here. (In text format, no pictures please. or use pastebin)

asterik 14.0.1
freepbx framework

Also if an agent is a member of 2 queues and not on a call and a call from each queue comes in she gets two calls simultaneously. Any setting to avoid that since technically her line is registering as free but two different queues coming at the same time is not helpful.

Seems like a bug to me.

Can you post screenshots of your Queue config?
Can you also post a failed call log?

This is not a supported version of Asterisk, it hasn’t been since Oct 2017. Either move back to 13 LTS or up to 16 LTS.

When I go to module updates Asterisk CLI 14.0.1 is what it shows and when I click check online it says I am up to date.

Sorry was looking at the wrong setting.
Current Asterisk Version: 13.22.0

Do you have FollowMe enabled on that extension?

1 Like

Seems like it’s follow me, then you can change to not call follow me. (instead of call as dialed)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.