After upgrade vom 13 to 15: "chan_sip.c: Call from 123456 to extension 's' rejected because extension not found in context 'from-trunk-mk'."

freepbx
configuration
Tags: #<Tag:0x00007f70297d7828> #<Tag:0x00007f70297d75d0>

(Isol) #1

Hi, we are trying to upgrade our well-working freepbx 13 phone system to 15, using the backup and restore feature of 15 (without “legacy CDR” as I was not sure what that implies. Almost everything worked out of the box - we have full internal calls, and averything outgoing seems to work also. But incoming calls all fail with:
"chan_sip.c: Call from ‘0123456789’ (a.b.c.d:5060) to extension ‘s’ rejected because extension not found in context ‘from-trunk-mk’ "
(Number and IP redacted).

I saw that in the trunk belonging to this inbound number we have a context “from-trunk-mk”, which is not set in the extensions (there we have “from-internal”. I then set “from-trunk-mk” in one of the extensions, but the error remains the same as shown above. Where else are the contexts used? How can I determine which settings I need to change?
Thank you for a hint, jcol


(Lorne Gaetz) #2

You have a trunk on your system configured with the user defined context ‘from-trunk-mk’. That context, if it exists, should be in the file extensions_custom.conf, it may not have transferred over as part of the backup.


(Isol) #3

Ah right. Great, that works now. Thank you very much for this hint!
Do I need to configure that also somewhere in freepbx, in addition to the asterisk .conf files? In the old system I think I never touched these, so I suppose this info comes from somewhere inside freepbx.

Now I have one error left - we have two trunks (two companies with different sip providers) here, one is configured with chan_sip, as are all the internal endpoints, and the other trunk is configured with pjsip. Both thrunks register correctly with the providers and the chan_sip trunk now works perfectly in- and outgoing, however it seems the pjsip trunk is never used outgoing and incoming I get error messages like

[2021-02-23 15:54:34] NOTICE[22817] res_pjsip/pjsip_distributor.c: Request ‘INVITE’ from ‘sip:+491xx123456@ims.telekom.de;user=phone’ failed for ‘a.b.c.d:5060’ (callid: p65551t1614095674m164995c1316s2) - No matching endpoint found

In another thread, this error is linked to non-standard ports, we have port 5061 for the chan_sip extensions but all the related pages look identical in both systems, so I am at a loss where to look for.
(Also, the dashboard tells me I have 16 bad extensions, but the extensions listed as bad are reachable!?)