After updating Freebx doesn't issue a RELOAD action - fw_fop, fw_ari, framework

UPDATE NOTICE: There are 3 modules available for online upgrades
fw_fop (current:
fw_ari (current:
framework (current:

I am using Freepbx 2.9 and asterisk The other day I received an update notice (shown on the above), so I updated it through Module Admin. However, after the update, when I deleted one of the trunks, then I went to the tab Tools-Asterisk Info, the trunk is still on the list of sip peers. So, I tried editing one of the trunks by changing it to a new IP address, then I went to the tab Tools-Asterisk Info, voila the IP address of the trunk is still the old IP Address it did not change. When I opened the asterisk CLI, I noticed that the freepbx was not issuing a reload action after submitting and reloading the changes. By the way I am using PIAF distro. Please help. Thanks.

After the update, I have to restart the asterisk itself to implement the changes on the trunks. Anyone had encounter the same problem? This is very annoying since I have remote gateways in different locations (cities) where it is connected to a dynamic IP addresses, everytime the remote location changes its IP address it becomes UNREACHEABLE as far as Freepbx is concerned. The only way to reached it is to restart the Asterisk server itself. Please help. Thank you.

Today I’ve update the module framework to version
I had the same problem with extensions, then I opened the Console e figured out that the freepbx was not issuing the Reload action.
I think this is a serious bug and need to be fixed as soon as possible.

Yes you are right, freepbx doesn’t reload. Are we supposed to submit a bug ticket for this type of problem? I haven’t tried doing it.

I’ve reported the bug, but they closed the ticket and said to go to the forum!

I made a comment there stating that the problem is showing on my 3 servers running freepbx 2.9, but not on freepbx 2.7. Hopefully they will take a look at it. Perhaps we should ask the forum if anyone have updated their freepbx 2.9? Perhaps many did not update their freepbx 2.9 but instead updated their system to 2.10 and that’s why nobody cares reporting it?

The Freepbx guys fixed this issue and released the Framework module version

this was only an issue on Asterisk 1.4 but had been tested on a later release and thus was not reproducing, should be fine now.

Thanks a lot.