After update 13 to 14 - "Error has Occured" when dialing an extension


#1

I had an awful time with the upgrade.
Used the distro script
https://wiki.freepbx.org/display/PPS/Upgrading+from+Distro+6
System would come up with the error
Exception: SQLSTATE[HY000] [2002] Can’s connect to local MySQL server…
the kvstore_sipstation error was fixed with
fwconsole ma downloadinstall sipsettings --tag 13.0.27.8
fwconsole ma upgrade sipsettings.

./post_upgrade throws this error

FATAL ERROR: Upgrade failed
Error running /usr/bin/mysql_upgrade - Retrying. Output was:
Version check failed. Got the following error when calling the ‘mysql’ command line client
ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO)

— but the server started up.

Got to the point where, when I started Freepbx the GUI would say “can not connect to askerisk”. After 3 minutes or so, the message would go away and the system seems to come up.
Every reference to extension 200 was “error” - manually fixed
After 3 minutes if I login and out from the CLI, the SQLSTATE error goes away (I assume this is connected to cannot start asterisk.)

Now, FreePBX answers with the IVR. None of the phones ring. Every time I try to transfer to an extension or call one extension to another – “An error has occurred”. Dashboard looks fine - no more errors. Extensions seem to connecting.

Not sure if I should keep trying to fix this or reinstall from distro and restore from backup. Will the problem restore as well? The starting delay worries me.

I’m running on a backup Freepbx server so I’m not crying in my beer – yet.
Did the MySQL repair – but this doesn’t repair everything.

Can anybody throw a few ideas at me?


(system) closed #2

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.