After FreePBX 15 Upgrade: "filestore" missing


(Hs) #1

The Upgrade was successful but the backup module does not work.
In Module Admin I see

Backup & Restore 14.0.10.10 … Disabled; Pending Upgrade to 15.0.8.83
Missing Requirements: * The Module Named “filestore” is required.

I can’t find the filestore module in Module Admin.

On command line it does not work, too:
fwconsole ma downloadinstall filestore
No repos specified, using: [standard,extended] from last GUI settings
Downloading module ‘filestore’
The following error(s) occured:
- Retrieved Module XML Was Empty

Any idea what’s wrong?

TIA,

HS


(Sshomi) #2

I have it on v15 and it is definitely called “filestore”. I don’t have a v14 to compare it with. Maybe try enable “unsupported” repo? You can also maybe try uninstall the Backup & Restore module in order for the upgrade to go through and then install it again.


(Lorne Gaetz) #3

Was it? What is the output of:

fwconsole ma list | grep framework

#4

I can confirm that ‘filestore’ is missing in the repo after a 14>15 upgrade with upgrade module http://mirror1.freepbx.org/modules/packages/versionupgrade/versionupgrade-14.0.11.tgz

So the Backupmodule does not upgrade from 14 to 15


#5

it says

fwconsole ma list | grep framework
| framework | 15.0.16.42 | Enabled | GPLv2+ |


(Lorne Gaetz) #6

I don’t know what’s going on, but I’m seeing issues as well. Until someone smart (like @kgupta1) can look at it, you can install filestore using this command:

removed

Edit - see post that follows, Kapil fixed it.


(Kapil Gupta) #7

Please try again to download ‘filestore’ module. This should be good now. Thanks.


(Hs) #8

Now I could download and install filestore.
The backup upgrade did now succeed.

Thanks for help.


(system) closed #9

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.