Advanced Recovery - Switch Service Error

Anyone else using Advanced Recovery and run into an error when trying to switch back to the primary from the secondary? I’ve been running into this on a pair of servers I have Advanced Recovery running on. Here’s a screenshot of the error…

Both servers can SSH and talk to each other. The primary still syncs nightly to the secondary but the secondary things it’s the active server when it is not and seems to not be able to run that command remotely.

Should also note, if I run that command from the CLI…I don’t seem to get any errors.

[root@freepbx asterisk]# ssh -i /home/asterisk/.ssh/id_rsa [email protected] 'fwconsole advr --unsetprimarydown b3c292bb-d3da-4b0e-ba65-65ab22b8717c'

We do and can’t say I’ve run into this exact error before.

I mean the error does say that the Host key verification failed but I am not sure how to square that against you just running SSH from the CLI without an issue.

I know in the past we’ve run into an issue if we configured the servers to talk to each other over HTTPS. The connection will fail and the secondary will think that the primary is down and unavailable if the certificate on the primary expires for example. We switched right quick to HTTP sync.

Again not sure what else to tell you on your particular issue other then open a support ticket since it’s a paid module and have them look at it.

Yeah, might have to. I agree, if I ran that command from the CLI and it threw errors, I’d suspect something else but GUI throughs errors and the CLI does not. Even running the command from the CLI, the GUI still says the secondary is active and doesn’t see the switch made from the CLI happen.

The only other thing that has helped us out when we were troubleshooting before was looking at the logs for Advance Recovery:


Take a look in there and see if you notice anything useful. There is also /var/log/asterisk/advrecovery_out.log but most of the time adv_recovery.log was what had useful info in it.

Hi @BlazeStudios “Host key verification” failed error generally means SSH key is not yet synced.
Could you login as asterisk user and then please try to ssh to other server , it may ask you for the ssh key verification then select yes and confirm ssh is working fine.
After that, again give a try from the UI please.

What is the asterisk user involvement in this process? Just for clarification, since per the instructions, all the SSH keys were passed with root@IP.

OK so when I did

ssh -i /home/asterisk/.ssh/id_rsa [email protected]

I didn’t get a fingerprint warning, same as when I did root@IP. However, when I did

sudo -u asterisk ssh -i /home/asterisk/.ssh/id_rsa [email protected]

I get the warning, I accepted it and switching services back via the GUI worked.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.