Advanced Recovery Module disabled, pending upgrade to 15.0.49

FreePBX 15.0.23; Sangoma Distro.

Got an alert on the dashboard on several PBXs that the Advanced Recovery module was disabled pending an upgrade. Tried running a manual upgrade on it, but it is missing a requirement:

  • EndPoint Manager module version 15.0.43.1 or higher is required, you have 15.0.41.49

Tried installing version 15.0.43.1 of Endpoint Manager by running the following command:

fwconsole ma downloadinstall endpoint --tag 15.0.43.1

Received the following error:

Unable to update module endpoint - 15.0.43.1, it does not exist:

So, I also checked the latest release, even on the edge repo, and it says that it is at version 15.0.41.49. This this by running:

fwconsole ma listonline --edge | grep endpoint

Am I missing something?

You need to pay for updates.

I am shocked at your answer.

I never asked for Advanced Recovery to be installed. It is there by default and came installed with the distro. Why am I being coerced into buying EPM to be able to not have errors on my system? This makes no sense to me.

I guess it is possible that the QA team let a module (Advanced Recovery) go stable while its dependency (Endpoint Manager) is not in stable yet.

EDIT: Nope, current stable is way past that, and nothing is in edge.

But you should not be shocked by how module licensing works. Did you install FreePBX blindly without doing proper research?

If you have never paid for EPM, then you would get all updates for EPM. Once you pay for EPM once, it will cease updating after your support time is up. One year by default.

Then remove it.

wow @sorvani - why are you responding to me this way? I am sure you were raised better than that… So sad :frowning:

This right here is a BIG problem, and frankly unbelievable. So, if I have left EPM alone with the free version I would be receiving updates. Why am I getting scolded for buying a 25 year license? I always understood the 1YR support was for updates inside the module, not the module itself. That’s crazy.

I can’t remove it. It doesn’t give me the option to remove it:

That seems like the issue here. Aren’t you part of the QA team?

Seriously?.

Yes, for updates to the module.
You can keep using it forever (25 years) on whatever was the last version was before support ran out.

Did you click check for updates first?
If so and the button is still missing, then command line.

fwconsole ma delete adv_recovery
fwconsole reload

Yes, seriously.

Hi @ben_itse

Did you get a resolution here? If you’re not using Advanced recovery, you can just delete the module entirely:

 fwconsole ma delete adv_recovery

If you have purchased licenses for both EPM and Advanced recovery, then you will need to renew your maintenance for EPM in order to update it to the minimum supported version for ADR.

Hi @lgaetz - when I try that command I get the following error:

[[email protected] ~]# fwconsole ma delete adv_recovery
The following error(s) occured:
 - Failed to run un-installation scripts

If the module has been removed, then the command worked.

@lgaetz - this is affecting other modules as well, including PMS, which is a required module. We are unable now to even hit the apply config button.

How can we revert to the free version of the EndPoint Manager? We don’t use that at all.

You can open a ticket of type Customer Service and Billing, state the deployment ID and request that the paid EPM license be removed.
https://wiki.freepbx.org/display/FPAS/How+To+Open+A+Support+Ticket

1 Like

@lgaetz - so, Customer Service removed the EPM License from the deployment. I no longer see the license under System Admin > Activation. However, EPM still won’t update past 15.0.16.19. Do I need to clear some setting or file before it can find the latest version?

What is the result of running:

fwconsole sa update
fwconsole ma downloadinstall endpoint --tag 15.0.48.1

@lgaetz

[[email protected] ~]# fwconsole sa update
Updating license for DeploymentID
Done!
No changes from original Licence.
[[email protected] ~]# fwconsole ma downloadinstall endpoint --tag 15.0.48.1
No repos specified, using: [standard,extended,commercial] from last GUI settings

Unable to update module endpoint - 15.0.48.1, it does not exist:
Updating Hooks...Done
Chowning directories...
[[email protected] ~]#