Administrators module diplsying NOTE: AUTHTYPE is not set to 'database' etc

I have a fresh install of FreePBX on CentOS 5.2 using Asterisk

I change the authtype=database in /etc/amportal.conf but the “NOTE:AUTHTYPE is not set to ‘database’ in /etc/amportal.conf - note that this module is not currently providing access control, and changing passwords here or adding users will have no effect unless AUTHTYPE is set to ‘database’.” still appears.

I looked around a bit and found something about changing /etc/amportal.conf to “authtype=webserver” but thisonly gives me access to the dashboard and the tabs along the top of the GUI (recordings, FOP and online.

When set to database I find I still have access and the module seems to be working but my customer has access to this page in order to manage their own passwords and I keep getting calls about it.

Has anyone had a similar problem and got any advice for me? I realise that this is not a high priority and I could easily delete the note in the .php file to remove it but I would rather fix the problem than hide it.

When you changed it did you do a amportal restart so that it knew to read the file and see the changes?

Yes I did the “amportal restart” and several reboots to no avail.

Sorry I did not add this sooner but it seems to be since I upgraded the “core” module using “module admin”.

I looked on the trac and can see where the change was made to add “AUTHTYPE=webserver” to the script in “page.ampusers.php” but I do not know how it checks amportal.conf to see if AUTHTYPE=database has been set.

header_auth.php is one place it checks

At the same time grep your amportal.conf file and make sure that there is only one instance of AUTHTYPE in it. If there are two I believe it only reads the first one, so if you made a change to the second one that would explain a lot.

I have done this and AUTHTYPE only appears once in amportal.conf “AUTHTYPE=database” I have also checked in “header_auth.php” and cannot see differences from the backup I took before I updated.

I have however run a restore using the “backup and restore module” followed by updating using module administration. I get the same result that Administrators works and I can add users and passwords which also work. But I do still get the “NOTE:” message on the Administrators page.

This is very odd :frowning:

How about checking all of your FreePBX modules and making sure they are updated to the latest.

If you are then file a bug report with exact details on how to make it happen. I can’t flip my system over at this time to test it.

Thankyou for your help fskrotzki.

I am going to flip back to the backup for now as I have a few tennants with some minor issues that need sorting. I will post a bug report once I have resolved their issues.

I appreciate all of the fine work you guys are doing for us novices. Keep up the good work