Admin web gui doesn't load after activating pbxact

I noticed the pbxact uc60 box was branded as freepbx.

* Sangoma EOL Testing for PBXactUC *
************************************
Sangoma License File: PASSED
Asterisk Running: PASSED
SSH Keys Installed: PASSED
Branding Module Name: oembranding
Branding Module: PASSED
Not Installed Modules: FAILED
1 : codex
Disabled Modules: PASSED
Operator Panel Installed: PASSED
Reload: PASSED
***********************************
Overall Status: FAILED
[[email protected] ~]# fwconsole sysadmin activate <redacted>
Attempting to activate against deployment '<redacted>'
Running /var/www/html/admin/modules/sysadmin/bin/activate_existing <redacted>
Asking for deployment <redacted>...Success!
Array
(
    [Extensions] => 60
    [Hardware-Locked] => Yes
    [Product-Name] => PBXact
    [Registered-To] => <redacted>
    [areminder_exp] => 2042-04-28
    [backup_password] => <redacted>
    [backup_username] => <redacted>
    [base_system_sku] => PBXT-UCS-0060
    [branding] => PBXactUC
    [callerid_man_exp] => 2042-04-28
    [callrecrpt_exp] => 2042-04-28
    [classofservice_exp] => 2042-04-28
    [confpro_exp] => 2042-04-28
    [crmpro_exp] => 2042-04-28
    [deploy_type] => PBXact
    [deployment_id] => <redacted>
    [deploymentid] => <redacted>
    [distributor] => No
    [extroute_exp] => 2042-04-28
    [global_lic_exp] => 2042-04-28
    [hostid] => M:TPSU6-RMWN8-9DH7E-HU8W7
    [license_version] => 2
    [outcalllimit_exp] => 2042-04-28
    [pagepro_exp] => 2042-04-28
    [parkpro_exp] => 2042-04-28
    [pbxact_exp] => 2042-04-28
    [pbxact_uc_exp] => 2042-04-28
    [pinset_pro_exp] => 2042-04-28
    [qxact_exp] => 2042-04-28
    [sysadmin_exp] => 2042-04-28
    [vm_reports_exp] => 2042-04-28
    [vmnotify_exp] => 2042-04-28
    [vqplus_exp] => 2042-04-28
    [webcallback_exp] => 2042-04-28
    [xdialer_exp] => 2042-04-28
    [xfax_exp] => 2042-04-28
    [zulu_exp] => 2042-04-28
    [zulu_users] => 1000
    [Expires] => 01-May-2030
    [Produced-By] => Schmooze Communications
    [Verification-Code] => <redacted>
    [deployment_name] => <redacted>
)
Setting permissions...
Restarting httpd...
Done

Now the web gui won’t come up. I’ve had this happen before after an update,but I was able to get in port 2001 and there was a port conflict with sangomaconnect, I believe it was, on port 8443, I changed that to port 9443 and it resolved it. But now I can’t access the gui on port 2001 or 8443.

Trying to run service httpd restart gets this message:

[[email protected] /]# service httpd restart
Redirecting to /bin/systemctl restart httpd.service
Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.
[[email protected] /]# systemctl status httpd.service
â—Ź httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Wed 2022-06-01 12:13:07 CDT; 20s ago
     Docs: man:httpd(8)
           man:apachectl(8)
  Process: 7849 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=0/SUCCESS)
  Process: 26075 ExecReload=/usr/sbin/httpd $OPTIONS -k graceful (code=exited, status=0/SUCCESS)
  Process: 3156 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
 Main PID: 3156 (code=exited, status=1/FAILURE)

Jun 01 12:13:07 <redacted> httpd[3156]: [Wed Jun 01 12:13:07.713008 2022] [so:warn] [pid 3156] AH01574: module ssl_module is already loaded, skipping
Jun 01 12:13:07 <redacted> httpd[3156]: AH00112: Warning: DocumentRoot [/invalid/folder/name] does not exist
Jun 01 12:13:07 <redacted> httpd[3156]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:9443
Jun 01 12:13:07 <redacted> httpd[3156]: (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:9443
Jun 01 12:13:07 <redacted> httpd[3156]: no listening sockets available, shutting down
Jun 01 12:13:07 <redacted> httpd[3156]: AH00015: Unable to open logs
Jun 01 12:13:07 <redacted> systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Jun 01 12:13:07 <redacted> systemd[1]: Failed to start The Apache HTTP Server.
Jun 01 12:13:07 <redacted> systemd[1]: Unit httpd.service entered failed state.
Jun 01 12:13:07 <redacted> systemd[1]: httpd.service failed.
[[email protected] /]# netstat -tulpn
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
tcp        0      0 0.0.0.0:8002            0.0.0.0:*               LISTEN      19334/node /var/www 
tcp        0      0 127.0.0.1:9443          0.0.0.0:*               LISTEN      7824/node /var/www/ 
tcp        0      0 0.0.0.0:5000            0.0.0.0:*               LISTEN      5970/letschat       
tcp        0      0 127.0.0.1:27017         0.0.0.0:*               LISTEN      1094/mongod         
tcp        0      0 0.0.0.0:3306            0.0.0.0:*               LISTEN      1445/mysqld         
tcp        0      0 127.0.0.1:6379          0.0.0.0:*               LISTEN      981/redis-server 12 
tcp        0      0 0.0.0.0:5038            0.0.0.0:*               LISTEN      2776/asterisk       
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN      670/rpcbind         
tcp        0      0 127.0.0.1:6001          0.0.0.0:*               LISTEN      5226/node /var/www/ 
tcp        0      0 0.0.0.0:53              0.0.0.0:*               LISTEN      979/dnsmasq         
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      973/sshd            
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      1680/master         
tcp        0      0 127.0.0.1:7999          0.0.0.0:*               LISTEN      19334/node /var/www 
tcp        0      0 127.0.0.1:4000          0.0.0.0:*               LISTEN      1042/python3.6      
tcp6       0      0 :::8001                 :::*                    LISTEN      5414/node /var/www/ 
tcp6       0      0 :::6081                 :::*                    LISTEN      5226/node /var/www/ 
tcp6       0      0 :::6082                 :::*                    LISTEN      5226/node /var/www/ 
tcp6       0      0 :::8003                 :::*                    LISTEN      5414/node /var/www/ 
tcp6       0      0 :::5222                 :::*                    LISTEN      5970/letschat       
tcp6       0      0 :::111                  :::*                    LISTEN      670/rpcbind         
tcp6       0      0 :::2579                 :::*                    LISTEN      3377/node /var/www/ 
tcp6       0      0 :::2580                 :::*                    LISTEN      3377/node /var/www/ 
tcp6       0      0 :::53                   :::*                    LISTEN      979/dnsmasq         
tcp6       0      0 :::6006                 :::*                    LISTEN      5226/node /var/www/ 
tcp6       0      0 :::22                   :::*                    LISTEN      973/sshd            
tcp6       0      0 :::8088                 :::*                    LISTEN      2776/asterisk       
tcp6       0      0 :::8089                 :::*                    LISTEN      2776/asterisk       
tcp6       0      0 ::1:25                  :::*                    LISTEN      1680/master

I run journalctl -xe and here’s the pastebin Automatic Pastebin from Sangoma OS 7 - FreePBX Pastebin
What’s it take to get this pbx back up?

image

It looks like there are port conflicts. Have you rebooted?

I noticed when I runt eh fwconsole sa eol check again it fails

Sangoma EOL Testing for PBXactUC *


Sangoma License File: PASSED
Asterisk Running: PASSED
SSH Keys Installed: PASSED
Branding Module Name: oembranding
Branding Module: PASSED
Not Installed Modules: FAILED
1 : codex
Disabled Modules: PASSED
Operator Panel Installed: PASSED
Reload: PASSED


Overall Status: FAILED

[[email protected] /]# fwconsole ma installlocal
Installing: codex
Installing codex…
This module must be licensed before it can be installed
Unable to install module codex:

  • Failed to run installation scripts
    Updating Hooks…Done
    Chowning directories…Done

Done. All modules installed.
Updating Hooks…Done
Chowning directories…Done

My research the only reference I can find to codex is reference to clearlyip module. I had been using the clearlyip mirrors but switched back to freepbx mirrors so I’m not sure why it’s checking clearlyip?

It’s a production system so I can’t do that now… And would like to have it up before closing time if possible.

Yes that is a clearly ip module. You can run fwconsole ma remove codex Note uninstalled modules shouldn’t be an issue

I ran that command, ran the EOL test again and still get the
Not Installed Modules: FAILED
1 : codex

sorry fwconsole ma delete codex Had to look

That says the Specified module not found but the EOL test passes now so that solves that part. Still unable to get to web gui tho.

Frankly I didn’t want their support to hold the presence of that module against you. They have policies to basically punt anyone with a clearlyip module whether at fault or not.

My guess from other output is still the port conflict. Short of a reboot I am not sure how to resolve that. Perhaps killing all of the services and restarting them manually.

@ozarktech I’ve flagged your initial post as off topic even tho it isn’t. You’ll want to edit it to remove sensitive info including dep id, fqdn, etc. after which it will be displayed.

edit - fixed now, with Andrew’s guidance below. Post visible again.

Even when things are flagged the flagged content can be seen. Additionally when they edit it there will be history of the previous edit with the bad stuff in there. Best thing to do is edit the post yourself as a moderator and then delete the history.

3 Likes

Thanks, I missed the sensitive info when I posted, I usually remember to remove it.
@jfinstrom Thanks for that. Seems the tech world is full of people pointing fingers. Usually my job to prove that the problem is somebody else’s problem, or it’s my problem and figure out how to fix it.

I ran fwconsole restart
I didn’t see any error messages in the cli. But I still can’t access web gui.
What’s the next step?

I’ve had something similar happen to me just yesterday. I set a secure port for UCP (wasn’t set prior) to something that didn’t look used and then the Apache server crashed and wouldn’t start properly.

I had to edit the file /etc/httpd/conf.d/ssl.conf and change or remove all the instances of the port in question, in your case I think it’s port 9443. Remove that line or change that port to something else that you know isn’t used and save the file and try to start httpd again.

Make sure to make a backup of the file before you edit to ensure you still have access to the original.

Thanks. Another tech here worked on it last night, he deactivated and reactivated pbxact and some other stuff, didn’t remember what he did or what made it start working :face_with_diagonal_mouth: But it’s working now. Did notice it looks like the backup only backups the configs, not the OS, so restoring from backup wouldn’t have fixed the problem, is that correct?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.