Admin page shows Asterisk status ERROR

OK, here’s what happened. I was attempting to find out what the Admin code for the Flash Operators Panel was. I found where to set this in the assorted configuration files (op_server.cfg) so I looked, and tried changing it. Since then, it’s been all downhill. After I tried changing it, and rebooting the Asterisk system (currently being used for testing, not live calls,) the FOP didn’t display correctly (shows all extensions as active, even when they’re not), and the Admin Status page for the Asterisk shows an Error for Asterisk, and no information on connections, etc.

I’ve tried changing the code back in the op_server.cfg, which hasn’t corrected anything. If I attempt to use the “Asterisk Info” add-on (previously installed), it reports “The module was unable to connect to the Asterisk manager.
Make sure Asterisk is running and your manager.conf settings are proper.” At no time have I made changes to manager.conf.

I can still call out from the system, calling in does not work, no ringing, nothing.

Under the Admin page, the options for Extensions, and Day/Night Control, are unavailable, and cannot be clicked. Other options are working OK.

I’m really hoping I won’t need to re-load the system, and re-setup everything again.

FreePBX version:

Thank you,

Here’s an update to this issue. I attempted to load an additional module (Blacklist) to try to force the system to update itself (I know, not necessarily the best idea) Module Admin, on attempting to apply the configuration changes, gave me the following error / warning message:

Checking for PEAR DB…OK
Checking for PEAR Console::Getopt…OK
Checking for /etc/amportal.conf …OK
Bootstrapping /etc/amportal.conf …OK
Parsing /etc/amportal.conf …OK
Parsing /etc/asterisk/asterisk.conf …OK
Connecting to database…OK
Connecting to Asterisk manager interface…Thu, 16 Jul 2009 14:55:03 -0400 - Unable to connect to manager (111): Connection refused
[FATAL] Asterisk Manager Connection Failure Failed to connect to the Asterisk manager through port: 5038

Editing manager.conf to remove the IP I had (almost a week ago) added for the bindaddr in the [general] section, resolved the issue. Asterisk now shows as OK.


That solved my problem, I was almost reinstalling the whole stuff ehehe…