Adding SILK codec


I am using FreePBX 2.11 with Asterisk 11.5 and added the the SILK codec ( to my asterisk installation. In order to make it available to asterisk I had to create /etc/asterisk/codecs.conf where I defined new codecs such as silk8, silk16 and silk24.

Now my issue is that I would like to make these available in FreePBX under the menu Settings -> Asterisk SIP Settings. Any recommendations on the best way to achieve that?

Right now I am manually modifying the codec allow statements /etc/asterisk/sip_general_additional.conf (to allow silk) but each time I modify any settings in FreePBX my manual settings get reseted.

Thanks for you input.


To answer my own question in the hope that it can be useful to someone:

Simply add the codec allow parameters in sip_custom.conf to override the ones from the web interface.

How you’ve done it? when i add allow=silk8 to any of sip.conf files my outbound route stop working

Did you load onto your system? You can’t use a codec that is not installed.

Please Google it before you ask how.

of course i added it using this tutorial
It works perfect in internal network but when i call outside i hear that abonent busy

Please post full config and log output of a failing call.

What type of trunks are you using? Does your trunk provider support silk?

You’re right! Trunk provider doesn’t support silk. Somehow i decided that client-asterisk connection will use silk and asterisk-provider connection will use something else. :slight_smile: Thank you