Adding a "wait" between an external number and the extension

I can’t figure this one out.
I am trying to add a phone number with its extension to a DSS key on a Yealink phone using Endpoint Manager. I would like for the number to be dialed, and then for the phone to wait for a key press before dialing the extension.
So far, I tried these:
-Commas, which pause but don’t wait
-Semicolon, which seem to be ignored
-$Cwc$ command, but the call fails

Any ideas? Thank you!!!

According to

$Cwc$ should work. Make sure that you have the details right, and try from the phone web interface in case EPM is causing the trouble.

If no luck, you could use two buttons: one dials the number, the caller waits for answer then presses the other which sends DTMF.

Another approach, do it on the PBX:
For example, if you are calling the Acme company, whose number is 12125550123 which you would call using mytrunk and which has 3-digit extensions, create a Custom trunk called Acme with Custom Dial String set to PJSIP/12125550123@mytrunk,300,D(ww$OUTNUM$)
Then, create an Outbound Route that routes to Acme, after any Emergency Routes but before your regular routes, with prepend (blank), prefix 999, match pattern XXX

Now, from any phone you can dial 999345 and you will get extension 345 at Acme.

Finally, just set a speed dial key on the Yealink that dials 999345.

Stewart1, thank you very much!
I got it working, I hadn’t realized I had to enable the Enhanced DDS Keys first. For other newbies as me, this is what I did:
-In the Endpoint Manager>Edit Basefile, I added features.enhanced_dss_keys.enable = 1
-I went to the phone’s web interface (type the phone’s IP address in a browser, the user is admin and the password is found at Endpoint Manager>Global Settings)
-I went to DDSkey>Line Key and I added a Custom Key with this value:
where 1112223333 is the external phone number to dial and 4567 is the extension. This dials the number, wait for a connection, waits 2 more seconds, then dials the extension.

In practice, I find it that this works the same as using commas as a pause like 1112223333,,,,,,,,4567 as there is no prompt for the user to agree to dial the extension. Also, I could not get it to work from EPM, since there is no “Custom Key” type for the line keys. That means that it gets wiped out any time I update the phone configs from EPM.

I might have to stay with the commas for now, unless somebody can shine some more light here.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.