AD directory sync not syncing on schedule, only manually

I have Freepbx framework 15.0.28. I have the pbx syncing 2 AD’s and configured to auto sync every 6 hours. I am noticing that they are not syncing, however, when i go to cli and do this

fwconsole --sync-all --force --verbose

the sync is successful and Freepbx picks up the changes in the directories.

Can anyone point me in the right direction of how to debug this issue, is there a log to look at?

thanks in advance

The obvious way to schedule this is to manually set up your crontab to handle it for you.

Log in to the Console (SSH or log into the machine) as root.

Enter “crontab -eu asterisk”. This will edit the “asterisk” cron jobs.

Add an entry that kicks off whenever you want it to (6,12 for two updates at 6AM and Noon during the day for example) and use the command you typed to make it happen.

It may be that you need to spell out the full pathname for fwconsole (sometimes needed the program to run) but that should ensure your sync is happening.

Dave, i don’t understand. In the directory config, there is a setting for how often to sync. presumably, FreePBX has some cron that is doing this based on that setting…why do i need to create another cron setting to do what freepbx seems to want to do?

Because the way you’re doing it isn’t working?

if you want a software solution, put in a ticket.

Dave, in the past, this was frowned upon. I had several heated discussions with Andrew about this. I hope the attitude about putting bug reports in has changed and I will add a ticket in.

If there’s a problem with the automated solution, the only way to fix it is to submit a ticket and let the maintainers know there’s a problem. That way, they a) know the problem exists and can work to recreate it or b) identify that there’s not a problem and try to figure out what you did to make it not work.

The fact that there’s a work-around means that there isn’t necessarily going to be a “high priority” issue, but getting it documented can’t be wrong.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.