"Activate" button not working in FreePBX 12

I’m spinning up a new FreePBX system (by cloning an existing drive) and the Activate button in SysAdmin isn’t working. I don’t really need the free SysAdmin license since we’ll be adding a system builder license anyway but since there is no longer a “License” tab in SysAdmin I don’t know of any other way to tie the system to a given deployment.

Additional info:
PBX Firmware: 6.12.65-27
PBX Service Pack: 1.0.0.0

When I click “Activate” the browser does some thinking for about 5 seconds then returns to the same screen that says I have 2 offers…

Can you let me know what version of Sysadmin you are seeing this with?

System Admin 12.0.28.4 Stable Schmooze Com Inc. Commercial Buy Enabled

The only time that button wont work is if it can not reach out API server meaning either network or DNS is not setup correctly.

I don’t know what to say Tony, module updates seem to work along with the RSS feeds on the status page! That would tell me the network and DNS is just fine…

can you ping outbound like google.com?

Try and restart apache just to make sure.

Yes, I was able to ping google - but I noticed a 3 or 4 second delay in the name resolution so I changed the DNS server entries. Restarted apache and it finally worked :slight_smile: Thanks for your attention to the matter.

ya if it was taking that long it would time out. I think we only allow 3 seconds to reach the API before we time out otherwise the page would never load.