Accessing FreePBX outside of LAN

I have a working FreePBX machine using the latest version. All is working fine from within the LAN and I wanted this machine to be accessible from the outside.
I have a static public IP address in place so I wanted to be able to communicate from users within the LAN when I’m on the road.

I’m successful connecting to our FreePBX machine via PPTP VPN with Zoiper but I would like to access it via “normal” communication since I have the static IP address.

Can someone point me to a “How-To” on how I can make this work.


Hello mydxbtester. From my understanding and what i did to make mine work with the outside world. Is you need to port forward a few ports to see outside. First port is 5060 second port is 10000-20000 both ports need to be UDP not TCP or Mixed. Second thing is make sure you turn off Allow Anonymous Inbound SIP Calls and Allow guests to off. This way no one can try to Hack you like they did to me. Hope this helps Not sure if I’m missing anything.

You should avoid port forwarding. Use a vpn tunnel, secure and safe. If you don’t care and you are using a softphone, use iax to register an extension. Port forward 54569 udp from wan side to 4569 of your freepbx and you are good to go.

Astbox is right VPN is better and secure. But sense in my case i never did a VPN before i only know how to do port forwarding my self. This is something on my to do list is to learn VPN next.

Thanks for the reply guys.

I port forwarded 54569 to 4569 from my Fortigate, anything that I have to do with my FreePBX? Unable to connect from my FreePBX using IAX to register my extension.

Set in the iax extension the requirecalltoken option to no and try again. In you iax softphone remember to put your publicip:54569 to send the packets to the right port.

No avail, I’m still not able to connect to my FreePBX even when outside of my network.

Even when not using VPN and port forwarding only 5060, 10000-20000 UDP ports. I get “registration refused” with iax2.

Are their other settings which I had to manage on FreePBX? NAT is already enabled and public IP too.

Connecting via PPTP VPN which I had configured works fine but what about directly connecting via our public IP.

Note: Nothing shows in /var/log/asterisk/full after I try registering from iax2.

5060 and 10000-20000 are for sip. Make a sip extension and try again.