Aastra XML Scripts with FreePBX 2.10

I just updated using yum update to the new Aastra-xml-scripts. Now my 480i Phones are getting configuration errors saying they can not connect to the Asterisk Manager. The Startup script gets the same error when trying to load a new phone. Any suggestions?

Yes…make sure your passwords are matched in /var/www/html/aastra/asterisk.conf

which version do you have. do a rpm -qa | grep aastra-xml-scripts.

Ok so I found an issue with the RPM upgrade spec. It was removing the manager settings that it installed on a upgrade. I have fixed the spec file and published a new RPM. They are syncing now.

Just do a yum update aastra-xml-scripts and it should fix your manager issue.

Also are you using the Distro Upgrade scripts. Its never a good idea to do yum upgrades and that is why we build upgrade scripts for the Distro

Thanks that worked. Yes I always use the upgrade scripts but ran the yum update today. I will make sure to only update with the scripts next time. Thanks.

Sorry for jumping in…

I have what I believe is the same problem as first reported, in the fact that the 6739i phone reports no connection to the Aterisk Manager, when using either the dnd or cfwd scripts. I do have another php button working for integration into SugarCRM though.

I have checked the password (which is default) for the asstra-xml user in both etc/asterisk/manager_custom.conf and /var/www/html/aastra/config/asterisk.conf

When I run check_install from the utilities directory it always fails at php-agi suggesting that I check the above files.

I have all the latest 2.10 modules updated. Any advice on where to look would be greatly appreciated.

…forgot to mention the xml scripts version is


I have some basic Linux skills, so please go gently…


Just to let anybody looking at this thread know that it was resolved by putting the # back in front of the

include manager_custom.conf

line in manager.conf, as it had been removed after following the guidelines when installing Web Meetme

Schoolboy error - my misunderstanding of the #include parameter in asterisk