Aastra/Mitel Remote Phone Setup Help - This should be an easy one ;)


I have a Mitel 6867i that I am trying to remotely connect to my FreePBX server as extension 4010. It seems to register with Asterisk but all calls in or out fail.


Under Advanced Network Settings, I changed:

  1. NAT IP: server’s external IP address.

… and nothing else under that heading. I see there is NAT SIP Port and NAT RTP Port pre-set in the 51000 area (both different). Are these the 10001-20000 port range set up in my firewall? I shouldn’t have to change these, correct?

In Global SIP Settings, I only changed:

  1.  **Proxy Server** to the server's external IP address
  2.  **Proxy Port** to the BIND port set in FreePBX under Asterisk SIP Settings
  3.  **Registrar Server** to the server's external IP address
  4.  **Registrar Port** to the BIND port set in FreePBX under Asterisk SIP Settings

I did not enter any user/pass info here.

Under Line 1:

  1.  **Phone Number**	4010
  2.  **Authentication Name**	4010
  3.  **Password**      its-a-secret

FreePBX Settings

I should mention that in FreePBX under extension 4010, I changed:

  1. Secret to its-a-secret
  2. NAT to Yes
  3. Port to the same as the BIND port set in FreePBX under Asterisk SIP Settings
  4. Qualify to Yes.

I know it’s old but it works:
PBX Firmware: 1.812.210.57-1
PBX Service Pack:

Also, I have several softphones that connect to this server remotely with almost no issues so I believe the port forwarding is all correct.

Could you offer a suggestion as to why this isn’t working?

Thanks in advance!


In Asterisk -rvvvvvv, I tried to make a call to a custom config extension (one that will play my on hold music) *135 and received the following:

[2017-05-25 11:44:02] WARNING[2939]: chan_sip.c:8916 process_sdp: ignoring ‘audio’ media offer because port number is zero[2017-05-25 11:44:02] WARNING[2939]: chan_sip.c:9124 process_sdp: Failing due to no acceptable offer found

Same thing when I call another local extension. I hope this provides clues. :slight_smile:


When I perform the setup, everything seems to work fine (extension calls, RX, Outbound, custom extensions)… until I reboot the phone. Then the Call Failed shows up again. All of the settings appear to be intact.

Check Codec Preferences under Global SIP, just to be safe.
If your phone is remote (the PBX is on a different network), double check NAT IP. What happens when you take it out and make it

Also, it might just me, but I have the Basic SIP authentication filled out for each Line, and nothing under Global SIP.
Not sure if that matters or not.


After removing the NAT IP and replacing it with AND a reboot, it appears the phone is now working!

Thank you for the suggestion!

Thank you for the response but still no luck.

Codec 1 is set to all.

Nat IP is correct; otherwise, I wouldn’t be able to make a call before a restart. If I take it out and put, I still cannot make calls (Call Failed).

If you fill out each line, that works fine but from what I know, you only need to do that for specific settings to those lines. IE: If you have more than one server and, say, line 1 connects to server1 and line 2 connects to server2, you would need different settings for each line. Global takes care of all except the details for each line.