Aastra 6867i Not displaying background

Using Endpoint manager to provision Aastra/Mitel 6867i using FTP. When selecting a background image that is properly formatted for the aastra the background will not display. I dug thru the configs and looked at the logs and I discovered what the issue is.
the config file for the phone has the background image config line configured as this
"ftp://(servername or IP)/(path to file)
instead of
ftp://(username:password)@(servername or IP)/path to file

I watched the vsftpd log when I rebooted the phone. After the phone pulls down it’s config files correctly and just as the phone finishes booting I see a log entry from the IP of the phone showing that it is trying to log in as anonymous with it Failing Login.

When trying it with HTTP or HTTPS I still run into the same issue that the Freepbx server requires auth to hit the location of the image and Endpoint manager does not build the the proper URL string to include the auth for the background image.

EDIT: Forgot to include versions:
Freepbx Version
Endpoint Manager Version:

Further testing. So I have tried turning off HTTP Auth for provisioning still could not get it to work. I tried hard coding the address in basefile edit. Tested that the url worked from a web browser and still would not work.
So I decided to copy the Image file to a completely different server.
Using FTP with Auth I was able to hardcode the URL in the basefile at the alternate source and have the phone display the background.

I used the images that were uploaded to Freepbx for the test so the only difference was the source of the file.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.