Aastra 6755i always reconfiguring itself

I have 10 Aastra 6755i connected to a local VOIP provider at work. I wanted to learn basics of a PBX server so I installed Freepbx. I set it up using a softphone (zoiper) and a voip.ms sip trunk. Everything was working fine. So I wanted to test the Aastra phone with my installation.

I factory reset 1 phone and erased the local setting. I then tried to configure it to my new Freepbx server. On reboot, the phone reconfigured itself to the local VOIP I am using in our working environment. So I unconnected it from my network and connected it on a small network just for my test. It worked. I bring this setup back to my home and when I reconnected the phone on my home router the telephone reconfigure itself again to my working environment.

How is that possible? I factory reset the phone and erased the local settings. When I logged to the phone webpage I carefully checked that all settings were gone. Am I missing something?

Thank for your help.

I have read the EPM wiki’s and I think I understand the basics. In a network EPM send configuration to phone with different settings based on phone type and macs.

If I factory reset the phone, erase locals settings, take the phone outside of the network and connect it, how could it find it settings back? The phone cannot find the server back(we just erased the settings) and the server can’t find the phone (in my understanding) because it’s not in the same network and can’t multicast over the internet.

Thank you again for your answers.

EPM doesn’t use any multicast. It’s either tftp (not recommended for Internet) ftp, sftp, http or httpd depending on the capabilities of your SIP terminal.

tftp, sftp, http or httpd are not the proccess used to detect a device. It is a communication protocol.

EPM use multicast:

I send you back your quote from the previous answer you gave me:
“You must not have read our wiki on getting started because if you used the EPM you would not have this issue.”

Please read:

Please don’t help me if you only want to prove i’m dumb…
If I was a Freebpx expert I wouldn’t be asking those simple questions

I don’t know where you would think I am trying to make you look dumb.

The protocols listed are the ones used to download the config to the phone.

Relative to what you posted:

The EPM supports provisioning the phone to receive multicast paging, the multicast is not part of the provisioning process.

Additionally the discovery mechanism does not use multicast, it uses broadcast to make sure the local ARP table is populated then looks at the MAC address vendor portion to identify the device.

None of these are FreePBX exclusive, they are IETF standards.

The ability to auto-discover the phone is not a requirement. Certainly it won’t function off the local LAN.

What you have to do is tell the phone the address, protocol and any authentication information to download the config. You can manually program these items into the phone or you can use DHCP boot server options.

Does this make sense?

To answer how your phone keeps reprovisioning itself. You have to reset to defaults and clear the local config to make sure your previous providers provisioning server information is removed. There is a small chance that you have OEM phones that have this information hard coded. If you can’t change the configuration server IP you may be in this condition. The good news is it usually is a URL and you can make an entry in your local DNS to point the providers URL to your provisioning server.

Your answer is really complete. Thank you very much for your time.

The phone is not currently located in the same building as the server. I factory reset the phone and delete the local config. At reboot the phone reload is settings and reconnect to the server. I guess that the hard coded phone is the only answer to this but it’s weird because our service provider is not a big company.

Thank you again for your answer and sorry for the complaint about your intention.

log into the phone and check the configuration section and see what is listed for the boot server.

Yes I am very interested myself, that’s why I asked you to check the configuration server settings after you reset the phone.

After I reset the phone and erased local config I logged into phone’s web UI and navigate to each single page: no settings left, only blank or default config(

What is the Boot version? Mine is version Could it contain server info? Is it updatable?

What firmware?


if you can’t then your dhcp server is sending option 66. try upgrading to the latest firmware (
also please verify that after the reset that the configuration server is showing as