Aastra 57iCT "Cannot Display" error using new Endpoint Mgr & REST Apps


(David Schargel) #1

Congrats on the beta release.

We were already using Endpoint Mgr and even before installing REST Apps, I noticed a new line at the bottom of the configs in tftpboot. I did not pay much attention to it. I just assumed it was harmless and for the new forthcoming REST Apps:
action uri registered: http://10.100.10.08:88/sync.php

Now, with REST Apps 2.11.0.9 & REST API 2.11.0.8 installed, the Aastra 57iCT displays a “Cannot Display” just after a restart and the message is there until you press the Done soft key.

Commenting out the action uri registered line makes the error “Cannot Display” go away.

httpd access_log shows simple access:
199.15.216.70 - - [09/Nov/2013:15:24:12 -0800] “GET /sync.php HTTP/1.0” 200 - “-” “Aastra57iCT MAC:00-18-5D-3B-C0-CD V:2.6.0.2019-SIP”

httpd error_log has a host of issues, but none that I think are related:
[Sat Nov 09 14:45:10 2013] [error] [client 199.15.216.70] File does not exist: /var/www/html/restapps/favicon.ico
[Sat Nov 09 14:53:04 2013] [error] [client ::1] PHP Fatal error: Call to undefined function parkpro_device_get() in /var/www/html/admin/modules/restapi/modules/parkpro/controllers/parkpro.php on line 78
[Sat Nov 09 14:53:04 2013] [error] [client ::1] PHP Fatal error: Call to undefined function parkpro_get() in /var/www/html/admin/modules/restapi/modules/parkpro/controllers/parkpro.php on line 33

Thanks,

David


(Tony Lewis - https://bit.ly/2SbDAyc) #2

Did you follow the setup guide? http://wiki.freepbx.org/display/FCM/RESTful+Phone+Apps-Adding+a+RESTful+Application+to+a+device


(David Schargel) #3

Yes, and I just double-checked it again. I just also created a new template just to see what would happen. No go all around. :frowning:

What else may I try?

David


(Tony Lewis - https://bit.ly/2SbDAyc) #4

Are you have a licensed copy of RestApps and RestFUL API on your system? This error makes it look like you do not have licensed copies of those modules.


(Tony Lewis - https://bit.ly/2SbDAyc) #5

Do any of the other Apps like Follow Me or DND work?


(David Schargel) #6

Tony,

Yes, the license was actives for this deployment with the free 3 month license. And, yes, all the Apps are working (DND, Follow Me, and Parking). It’s just the “Cannot Display” message appearing whenever the phone is restarted.

David


(Tony Lewis - https://bit.ly/2SbDAyc) #7

Ahh I see the issue. Their is a bug in the sync script. It assumes you have Park Pro since that is the application we did our testing on. This should be resolved in the next release later this week.

The sync script is called on startup of the phone to have it light up any buttons that need to be on since it was offline it may of missed some updates.


(Tony Lewis - https://bit.ly/2SbDAyc) #8

Bug ticket opened. http://issues.freepbx.org/browse/FREEPBX-6926


(David Schargel) #9

Confirmed as fixed. Thanks!


(Tony Lewis - https://bit.ly/2SbDAyc) #10

No problem. Sorry about that. I hate bugs more then anyone else in life. You should see a new version later today that adds the new Conference Room app. We are next working on a login and logout app that interacts with updating EPM as you logout of the phone and log in as a new extension.


#11

I have the latest EPM and Rest API module.

Rebooted the server.

I am still getting the error ‘Cannot display’ if I select DND for example on the 57i. none of the new apps seem to work.

The license is applied and I did follow you instructions - which all worked well.

Can you help me to debug this problem.

I wonder what fixed it for dschargel. As he seemed to have the same problem. but your latest modules fixed it for him, but not for me.
I was waiting for the new updates to see if it fixed it. I was a bit suprised it did not work.

I think what you are dong though is moving in the right direction.


(David Schargel) #12

Norskperson,

I started by reviewing the http access_log and error_log before I manually editing one of the phones .cfg file in tftpboot to remove the action uri registered line for sync.php to confirm that it had something to do with that PHP page. What does your http access_log and error_log files show?

David


(Tony Lewis - https://bit.ly/2SbDAyc) #13

His issue was on boot up of phone when it ran a sync.php script it gave a error on the screen which we resolved. Going to actual apps works for him on his phone. Your issue sounds like the apps are not installed or licensed correct as it can not find the app.

You setup the API users? Look at the URL for the button that has DND and see if you can go to it in a browser and also make sure you can navigate to it from inside the CLI.


#14

I am licensed - checked that in the license in sys admin
It is connected to a user ( extension) - checked that
checked the keys setup in the Aastra57 setup -
Top soft keys:
top soft key 4
Type: Xml-api Label: follow-me Value: rest-api account: global

I wonder if as you say the apps are not install. How can I check that please? it is calling something when the key is pressed. It cannot find the program to run though.


(Tony Lewis - https://bit.ly/2SbDAyc) #15

Try this. Go into sysadmin and click on port management and then submit that page and do a reload and test.


#16

NO that did not fix it either.

I am sure the phone is looking to a location that does not exist.

Some other functions do work - for example: ‘services’ work.

call work the phone does register and ring when called.


#17

Its still not working. I downloaded the latest firmware from AAstra. Still not fixed. I get an error on the phone - for example - when I hit DND - please wait - then cannot display.

Where are these files located please? so I can at least have a go at debugging. http access_log and error_log - please.

EPM is working to some extent - For example if I ask for a reboot of the phones - it does reboot the phones - so it can’t be too far from working.

My EPM also programs the keys correctly - at least the lables and expansion module keys are ok. As are the short cuts.

AllI need is a bit more help debugging and i am there.


(system) closed #18