A200 Analog Card Missing


(Bryce Holland) #1

Greetings, I am in the final stages of implementing a PBXAct 400 at a school. Everything is working great with the phones and PRI. I am trying to setup an extension to use one of the FXS ports on the A200 analog card for the old intercom paging system.
The “lspci” command shows the card in the system, there are just no channels listed in the “Analog hardware” tab of the DAHDI config.
I have been trying to learn how to setup an extension to use a FXS port, so this was obviously a surprise to me.

Thank you for your help.


#2

That card has daughter cards in it for the ports. Check if they are correctly seated.


(Bryce Holland) #3

Thank you for the reply. The ports have lights on them, would they be on if they weren’t seated properly?


#4

Probably not, but just to be on the safe side, try to reseat them. Only other possibilities are incorrect/missing wanpipe/DAHDI configuration or DOA card. Have you run the wanpipe initial setup script?


(James Zhu) #5

Do you plugin the 12V power cable?


(Bryce Holland) #6

This card was installed by Sangoma when this unit was ordered, so I would be surprised if it was incorrectly installed. Before I shut it down to check, which wanpipe setup are you referring to? I have only performed the initial DAHDI config, which automatically setup the PRI card. I have not done anything related to wanpipe as far as I know.


#7

Sangoma cards run a software layer called wanpipe in order to interface with DAHDI. For DAHDI to recognize the card, wanpipe must be configured first. Just in case you might be confused, A200 is not a PRI card, it is an analog card.

Take a look at this link, go to configuration section.

https://wiki.freepbx.org/plugins/servlet/mobile?contentId=56230130#TelephonyCardsforAsterisk-Configuration


(Bryce Holland) #8

Maybe I am getting confused, but here is what I see when I run “wanrouter hwprobe”
hwprobe

and then “wanrouter status”.
status


#9

Have you run wancfg_dahdi ? That script should configure DAHDI for your card. It seems you have a PRI card and an analog card. wancfg_dahdi should take care of configuring DAHDI for both of them, just follow the instructions that the script presentes when run.


(Bryce Holland) #10

Yes, this system is using a PRI. Will running wancfg_dahdi affect that? I already have inbound and outbound routes setup, and have just cutover the PRI to this server. I thought I had already configured DAHDI when I went to DAHDI config in the PBXAct web UI.


#11

Sangoma cards need wanpipe to be configured first in order for DAHDI to be configured after. wancfg_dahdi takes care of generating the needed configurations. If wanpipe is not running then DAHDI can’t “see” the card. If PRI has already been configured before, just select the analog card when re-running wancfg_dahdi. The script will find all cards and you just configure the one you want.


(Chris Dolese) #12

try this from the linux command line … its a text based wizard , all fo the defaults should be fine,

setup-sangoma

run it once and restart asterisk , the end i think it gives you this option anyway

let us know if the channels appear or not after doing so


(Bryce Holland) #13

What will that command do? No offense, but I just placed this server in production, so I don’t want to run a command that sounds like an initial wizard that will wipe out all of my current setup. I didn’t realize that the analog ports weren’t available until I tried to use them.


(Bryce Holland) #14

Unfortunately this didn’t work. In fact, it caused a busy signal. I had to open the settings in DAHDI config, re-save them, and then restart DAHDI and Asterisk to get it back.

I still don’t see the analog channels, even though the wancfg_dahdi command saw the card and walked me through configuring it.


#15

Not sure what else to tell you. Maybe it is time to contact Sangoma Support team.


(Bryce Holland) #16

I tried. Although a support package was purchased with this appliance, I can’t create a ticket from my Sangoma account since I don’t have any support credits. Very confusing.


(Bryce Holland) #18

Dolesec: my apologies if my reply offended you, I have since learned more about the “setup-sangoma” command and what it is supposed to do.

This has been a long and tedious road. We were able to contact Sangoma support, and we suspect a faulty A200 card, which at one point completely disabled the A102 PRI card!

We removed the A200, but the DAHDI config would not setup. Guess what final command that Sangoma support used? That’s right, the “setup-sangoma” command. That was the final fix.

We still have more work to do, and we still need a functioning analog card, but I sincerely appreciate everyone’s help and patience!